summaryrefslogtreecommitdiff
path: root/x11-libs/libfm-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /x11-libs/libfm-extra
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'x11-libs/libfm-extra')
-rw-r--r--x11-libs/libfm-extra/Manifest2
-rw-r--r--x11-libs/libfm-extra/libfm-extra-1.3.1.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/x11-libs/libfm-extra/Manifest b/x11-libs/libfm-extra/Manifest
index a748d2a03d0f..5a09e01b6e83 100644
--- a/x11-libs/libfm-extra/Manifest
+++ b/x11-libs/libfm-extra/Manifest
@@ -1,3 +1,5 @@
DIST libfm-1.2.5.tar.gz 1261152 BLAKE2B 30da6771ad4ab31be675a3af2ce7c9dd04e80be9f33b25300bf386f45f9fd652654e211c312d1e283a63cdbde4f5c8e3673a36fc0075e3b1981d9f5995683057 SHA512 0bc7910081cadc4c8c4648f3483fb5791e9480700400ded452dd5985e7fb0d8524f2c676f0171a5cd283422a13f240f40cfe5ccc8d10dce02dd784d62250b7cc
+DIST libfm-1.3.1.tar.gz 1290374 BLAKE2B 3df27fc6b4afd089e51cd36db0f764e9359b0c6373e0ff484aa7cd2ee99170530fb60f5757ade9263a5bdd1d6be9917debb66a19cc8e13c505431050b6f3a901 SHA512 82bbcb1b9c7d4543bcb075906bdc1554462b041ad936e2f0334ae478302b19808cdbfe6d0c86a039bbd72a2491f2d2ada61a324fe3933a8dde16a03d93bef2bc
EBUILD libfm-extra-1.2.5.ebuild 2565 BLAKE2B d39853407d9a146d8114f9f06c53551b0a800acfe15be1e425b6e5b0a7a4396ec912cf63d486537820c32a70628178e7111933f5be0dbc5b62203c85872a69af SHA512 f4775b74a6496c15115d8e2c79b8faeddbb6dd0e18cf93e5675d51f7d62c9b490dee85c9bfd8ca0f0b7a28e0f74913580a12ecef83aa89e944d226d8569a86a5
+EBUILD libfm-extra-1.3.1.ebuild 2579 BLAKE2B 57fddd0541183c3a571525d5da01d304150f50896a484dfaf772b22e1f602065c58db5b876ebab410d7044288377f02ccb8dcd3c9c1412684016bafc3cf3d5a2 SHA512 aec03e6d46edd9146cae44f17a6cd1a5577161512c0ca4a84307e9e31f61f19a0bd2efa20363f22f9720afe0a80a6e1bc2c200cd713370d6e87f97ce8f2898cb
MISC metadata.xml 493 BLAKE2B 5f295aa7bd56f402ee0452a48ef4a68088d4256bc33480bebe6406e144e4bcfdf3efbf92d39a2f166b6265c8ad9459543cd82cfdbd03e4fb29ffbf2c3a0735eb SHA512 12e967cd0e2f30984b1c3d826c65e33033391687210e1a39efc837871b671fd002f2e2d17673366dadcf74bb55cf2c253524eb7b5e200160b6d982974ad6249b
diff --git a/x11-libs/libfm-extra/libfm-extra-1.3.1.ebuild b/x11-libs/libfm-extra/libfm-extra-1.3.1.ebuild
new file mode 100644
index 000000000000..c4dff66b8025
--- /dev/null
+++ b/x11-libs/libfm-extra/libfm-extra-1.3.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools xdg-utils
+
+MY_PV=${PV/_/}
+MY_PN="libfm"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="A library for file management"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="https://github.com/lxde/libfm/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+SLOT="0/5.2.1" #copy ABI_VERSION because it seems upstream change it randomly
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.18:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ sys-devel/gettext
+ !!<=x11-libs/libfm-1.2.3"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ sed -ie '/^SUBDIR.*=/s#docs##' "${S}"/Makefile.am || die "sed failed"
+ sed -ie '/^[[:space:]]*docs/d' configure.ac || die "sed failed"
+ sed -i -e "s:-O0::" -e "/-DG_ENABLE_DEBUG/s: -g::" \
+ configure.ac || die "sed failed"
+
+ #disable unused translations. Bug #356029
+ for trans in app-chooser ask-rename exec-file file-prop preferred-apps \
+ progress;do
+ echo "data/ui/"${trans}.ui >> po/POTFILES.in
+ done
+ #Remove -Werror for automake-1.12. Bug #421101
+ sed -i "s:-Werror::" configure.ac || die
+
+ # subslot sanity check
+ local sub_slot=${SLOT#*/}
+ local libfm_major_abi=$(sed -rne '/ABI_VERSION/s:.*=::p' src/Makefile.am | tr ':' '.')
+
+ if [[ ${sub_slot} != ${libfm_major_abi} ]]; then
+ eerror "Ebuild sub-slot (${sub_slot}) does not match ABI_VERSION(${libfm_major_abi})"
+ eerror "Please update SLOT variable as follows:"
+ eerror " SLOT=\"${SLOT%%/*}/${libfm_major_abi}\""
+ eerror
+ die "sub-slot sanity check failed"
+ fi
+
+ eautoreconf
+ rm -r autom4te.cache || die
+ eapply_user
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}/etc" --disable-dependency-tracking \
+ --disable-static --with-extra-only
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+ # Sometimes a directory is created instead of a symlink. No idea why...
+ # It is wrong anyway. We expect a libfm-1.0 directory and then a libfm
+ # symlink to it.
+ if [[ -h ${D}/usr/include/${MY_PN} || -d ${D}/usr/include/${MY_PN} ]]; then
+ rm -r "${D}"/usr/include/${MY_PN}
+ fi
+}
+
+pkg_preinst() {
+ # Resolve the symlink mess. Bug #439570
+ [[ -d "${ROOT}"/usr/include/${MY_PN} ]] && \
+ rm -rf "${ROOT}"/usr/include/${MY_PN}
+ if [[ -d "${D}"/usr/include/${MY_PN}-1.0 ]]; then
+ cd "${D}"/usr/include
+ ln -s --force ${MY_PN}-1.0 ${MY_PN}
+ fi
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+}