summaryrefslogtreecommitdiff
path: root/x11-libs/libdrm/libdrm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /x11-libs/libdrm/libdrm-9999.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'x11-libs/libdrm/libdrm-9999.ebuild')
-rw-r--r--x11-libs/libdrm/libdrm-9999.ebuild38
1 files changed, 13 insertions, 25 deletions
diff --git a/x11-libs/libdrm/libdrm-9999.ebuild b/x11-libs/libdrm/libdrm-9999.ebuild
index 370a65ea93cc..f603cf783700 100644
--- a/x11-libs/libdrm/libdrm-9999.ebuild
+++ b/x11-libs/libdrm/libdrm-9999.ebuild
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-inherit ${GIT_ECLASS} meson multilib-minimal
+inherit ${GIT_ECLASS} meson-multilib
DESCRIPTION="X.Org libdrm library"
HOMEPAGE="https://dri.freedesktop.org/ https://gitlab.freedesktop.org/mesa/drm"
@@ -40,32 +40,20 @@ multilib_src_configure() {
# Udev is only used by tests now.
-Dudev=false
-Dcairo-tests=false
- -Damdgpu=$(usex video_cards_amdgpu true false)
- -Dexynos=$(usex video_cards_exynos true false)
- -Dfreedreno=$(usex video_cards_freedreno true false)
- -Dintel=$(usex video_cards_intel true false)
- -Dnouveau=$(usex video_cards_nouveau true false)
- -Domap=$(usex video_cards_omap true false)
- -Dradeon=$(usex video_cards_radeon true false)
- -Dtegra=$(usex video_cards_tegra true false)
- -Dvc4=$(usex video_cards_vc4 true false)
- -Detnaviv=$(usex video_cards_vivante true false)
- -Dvmwgfx=$(usex video_cards_vmware true false)
- -Dlibkms=$(usex libkms true false)
+ $(meson_use video_cards_amdgpu amdgpu)
+ $(meson_use video_cards_exynos exynos)
+ $(meson_use video_cards_freedreno freedreno)
+ $(meson_use video_cards_intel intel)
+ $(meson_use video_cards_nouveau nouveau)
+ $(meson_use video_cards_omap omap)
+ $(meson_use video_cards_radeon radeon)
+ $(meson_use video_cards_tegra tegra)
+ $(meson_use video_cards_vc4 vc4)
+ $(meson_use video_cards_vivante etnaviv)
+ $(meson_use video_cards_vmware vmwgfx)
+ $(meson_use libkms)
# valgrind installs its .pc file to the pkgconfig for the primary arch
-Dvalgrind=$(usex valgrind auto false)
)
meson_src_configure
}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- meson_src_test
-}
-
-multilib_src_install() {
- meson_src_install
-}