summaryrefslogtreecommitdiff
path: root/x11-libs/libast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
commit78754950ffa3aaba0f48b1ca1d505caa4a3dfbfa (patch)
tree285997f09f32d26633ba2beffd30c972a4ec87a2 /x11-libs/libast
parentbf99f8024d68382f76665735c70ae912331bc2ca (diff)
gentoo auto-resync : 04:10:2022 - 13:17:38
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/Manifest5
-rw-r--r--x11-libs/libast/files/libast-0.8-fix-implicit-func-decls.patch15
-rw-r--r--x11-libs/libast/libast-0.8.ebuild48
-rw-r--r--x11-libs/libast/metadata.xml25
4 files changed, 81 insertions, 12 deletions
diff --git a/x11-libs/libast/Manifest b/x11-libs/libast/Manifest
index a276813212bd..eda426185c3d 100644
--- a/x11-libs/libast/Manifest
+++ b/x11-libs/libast/Manifest
@@ -1,3 +1,6 @@
+AUX libast-0.8-fix-implicit-func-decls.patch 300 BLAKE2B adea9472e364e890fea8a9a41d8677d4e3b0309e969e46f0a87c0e7797d032a3d6ce212340075010fd7c74a6f8ae48bae29c502516221fc14a2228d7be291130 SHA512 1a57db8cb30184dca9415c11f4570722e3ff2b54ae9cdf650553fe89696751f78cb320aa794bb02bfff5879cc6d6501903dbe837ef5391d52b9f57daddf63870
DIST libast-0.7.tar.gz 508654 BLAKE2B 0c5bf31d5b73fe11d4665bc0d8e1c9a987b944fcdcd89106a47ebf01eb90c2895b3e74e39874b360e91f027b8beaf5698363e9920ad879bfd241b13ef0232870 SHA512 0af1d508af88ce0a2f29fe7841e23759be7c6540a1e2698980c289245ba284fdbf76c593e457c0cd6cfc54dcb6d891b01a3fd4d4a6ecc511fb2de698c9a3046d
+DIST libast-0.8.tar.gz 254188 BLAKE2B 02fc2872218f11cb4083d451377fdc46369c2ef7d1f0e547831dfdf4ecec2cd6aaf3453e9e8ef8431fbd5e3cd75e828e3c5967a6311853e7e87f583ef2be72c8 SHA512 266a479fdbfc479e233675fa7623488135c633fed9cb236ec0cee578fc5be83b88a2dbda8a304ee3a27384c96e93a4bdf40f60597660e09841380e0930dd93d9
EBUILD libast-0.7-r2.ebuild 874 BLAKE2B 67bd80db9c435a627497c57ba87ba5da08a675a8ee6d18911c69f215e0dad6af9535dfe91897d72ef9b254d163f59f9a22bbe39e1c2bb99d113a18d16e642d98 SHA512 3929b2100fc1149d860519b34eb42a36e05e9d5146d2b3ef2acb1173eb3265895526f7764699b4c02d21c1b20c627d506b475e5dc55be84d2c853248e9148c78
-MISC metadata.xml 737 BLAKE2B 9a8079635cfdf17d60cc75a0c8a28b61f5779a7bb8a3fdc5ef591df8caa670ca34f732e5ce601f11843e152d058c6a9e223cb30ea82e244c0ccd3adfb7d5d446 SHA512 630ec4769e0ee029af062b2087b0b288c89d49fef359e6b891614f5901087e115338dcd65be0eef51681f02a3b1c2b2504c79925c10bfc04e3d168f804502592
+EBUILD libast-0.8.ebuild 955 BLAKE2B 22dcbb6a97548918de58b473778042374cae59167c81a189c37b408a6e5ccb598edc3596939a2fd9ee664112094309538259f183d7aef04ac5e47eaac071d70f SHA512 30f84dbc64d8e9f187efa4e8c800e81de73ca694db761913b03af87b53dba2adc655aacb7b60f4b319b8ebf9d56354e60bd6e5083dfc511cef20734e8f87dbf3
+MISC metadata.xml 823 BLAKE2B 2b89b024a4867ac7dacd136f1aa57523f7d74947c8d93ce92231c9b0f58e73f2dbdc67bc82c40a9dacdab4722f37bdf002f766ff194f94b8c2245cee1cdf61f4 SHA512 ce3a1ed303a48743b3f419415a7ed1b0947865127ca75fc23f3e2155c21d7d9e63a7df782f69655d144c86631bcb26af910d5cba079ae6d0a71135061940dee6
diff --git a/x11-libs/libast/files/libast-0.8-fix-implicit-func-decls.patch b/x11-libs/libast/files/libast-0.8-fix-implicit-func-decls.patch
new file mode 100644
index 000000000000..34e55f7d43aa
--- /dev/null
+++ b/x11-libs/libast/files/libast-0.8-fix-implicit-func-decls.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/871705
+--- a/src/snprintf.c
++++ b/src/snprintf.c
+@@ -2,6 +2,11 @@
+ # include <config.h>
+ #endif
+
++#include <ctype.h>
++#include <stddef.h>
++#include <string.h>
++#include <stdio.h>
++
+ #include <errno.h>
+ #if defined(HAVE_STDARG_H) && (HAVE_STDARG_H != 0)
+ # include <stdarg.h>
diff --git a/x11-libs/libast/libast-0.8.ebuild b/x11-libs/libast/libast-0.8.ebuild
new file mode 100644
index 000000000000..396c0cb77b4d
--- /dev/null
+++ b/x11-libs/libast/libast-0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI="https://github.com/mej/libast/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="imlib cpu_flags_x86_mmx pcre"
+
+RDEPEND="
+ !sci-astronomy/ast
+ x11-base/xorg-proto
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ media-libs/freetype
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with imlib) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ --with-regexp=$(usex pcre pcre posix)
+}
+
+src_install() {
+ default
+
+ dodoc DESIGN
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/x11-libs/libast/metadata.xml b/x11-libs/libast/metadata.xml
index 5b5095039f39..542463f59189 100644
--- a/x11-libs/libast/metadata.xml
+++ b/x11-libs/libast/metadata.xml
@@ -1,15 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription>
-LibAST is the Library of Assorted Spiffy Things. It contains many
-spiffy things, and it is a library. Thus, the ever-so-creative name.
-LibAST has been previously known as libmej, the Eterm helper library
-which nobody really understood and certainly never used. My current
-plan is to gradually remove some of the neat stuff from Eterm that
-could be made generic (things like the theme parsing engine, the
-command-line options parser, perhaps the event engine, ...) and place
-it here in the hopes that others will find them useful.
-</longdescription>
+ <!-- maintainer-needed -->
+ <longdescription>
+ LibAST is the Library of Assorted Spiffy Things. It contains many
+ spiffy things, and it is a library. Thus, the ever-so-creative name.
+ LibAST has been previously known as libmej, the Eterm helper library
+ which nobody really understood and certainly never used. My current
+ plan is to gradually remove some of the neat stuff from Eterm that
+ could be made generic (things like the theme parsing engine, the
+ command-line options parser, perhaps the event engine, ...) and place
+ it here in the hopes that others will find them useful.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">mej/libast</remote-id>
+ </upstream>
</pkgmetadata>