summaryrefslogtreecommitdiff
path: root/x11-libs/libXt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 17:37:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 17:37:15 +0100
commitc7c8d625ecbe5f95c445995303ed9b0e1f0de507 (patch)
treef0e6e5b3d8a377cf309b6085c2c7a30e640f84a1 /x11-libs/libXt
parentd6fe3a53bdeea6b060d1755199cc2c27492dc14c (diff)
gentoo auto-resync : 10:04:2023 - 17:37:14
Diffstat (limited to 'x11-libs/libXt')
-rw-r--r--x11-libs/libXt/Manifest2
-rw-r--r--x11-libs/libXt/libXt-1.3.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/libXt/Manifest b/x11-libs/libXt/Manifest
index 35896f8b19ce..2c2cd2f6d40f 100644
--- a/x11-libs/libXt/Manifest
+++ b/x11-libs/libXt/Manifest
@@ -1,3 +1,5 @@
DIST libXt-1.2.1.tar.bz2 784610 BLAKE2B 69a1446a22acb50e625ab4a7b24b5db634d47a540d4543a3f58459dbb380d61aa4bbbde50328c76b2c31eaae3662a1c71cdbcf9bd3a0c915ae4e587f63fbee7a SHA512 6877af61ba91eeed6b6f80471b84f354ad0ec0827249c7ee0a00c13508063fe8d2696dd400a4bdbc6ca2ff67cbe1317ad5ac24522fd96099dc56535e33ca052c
+DIST libXt-1.3.0.tar.xz 688084 BLAKE2B e8ac62bee544521471f25d3138b88d8d740bf8701aa7b6c1badcb9f725659c2648f3fd31813e0a05f1091514323bcea0788319cd36dfa945213f83cae87afb7c SHA512 64c5978655135b925c3aaad86b1aa6a3f3b57ad8b3592bf142be616b8aa339a02c2fc7badfab9564ea8076ea8f37acfe31709ed528f5a1d251f2d116aa074118
EBUILD libXt-1.2.1.ebuild 887 BLAKE2B e02f6eb93eb829133807f01734cf666f62e0ae59bd5ff48857454c4e5ba7a7b1ce9eed3a9156e7b78b2b38e75038b96e74c0cbc3a405785a7643ae04ba46bb41 SHA512 4cd64255595ecf5db9659f696c1a8609fae80c7d98d5eb86019df48c40dc9c29f4cd57c558a7016e1035b6d214daac01d74fb619302d243c466df42c2627426a
+EBUILD libXt-1.3.0.ebuild 919 BLAKE2B 43c24a6980a02b6ffcf10ff6a6be297a099be3c265d91cfc64669a523b18d4bf8f18f7bf09c986663332645020c81c29f6a98b9789e398617107f2c1fb367335 SHA512 881729231bfe82bad425f1619b2840def4d1148f4f3ecf805f45c87ba7ae22c8088bab9bd581c0cadb2807b1d80aaf314518fd7b0af67fe2914e0afd31efe40f
MISC metadata.xml 336 BLAKE2B f3ceaf37a1b9096462f9c82a317f29ef6d144aff5051be6a92235ebb2155fd7f01efa71466c59c2de4fdda58f84b2c3d790a15010fb16c6836e37fa6f2485170 SHA512 bca56314490246cde70c6b3104a7458cb72d9995d7a833817a91add87ce89dabe08b542de9d80f493ad849a73aacc3b8556acda29fe683eaa6d8c34882bcd054
diff --git a/x11-libs/libXt/libXt-1.3.0.ebuild b/x11-libs/libXt/libXt-1.3.0.ebuild
new file mode 100644
index 000000000000..2672d4b45653
--- /dev/null
+++ b/x11-libs/libXt/libXt-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org X Toolkit Intrinsics library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libICE-1.0.8-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libSM-1.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ test? ( dev-libs/glib[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable test unit-tests)
+ --without-fop
+ )
+ xorg-3_src_configure
+}