summaryrefslogtreecommitdiff
path: root/x11-libs/libXdmcp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /x11-libs/libXdmcp
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'x11-libs/libXdmcp')
-rw-r--r--x11-libs/libXdmcp/Manifest2
-rw-r--r--x11-libs/libXdmcp/libXdmcp-1.1.3.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/x11-libs/libXdmcp/Manifest b/x11-libs/libXdmcp/Manifest
index a4a89b45b934..03d253f70036 100644
--- a/x11-libs/libXdmcp/Manifest
+++ b/x11-libs/libXdmcp/Manifest
@@ -1,3 +1,5 @@
DIST libXdmcp-1.1.2.tar.bz2 331518 BLAKE2B 1a6f98d03a2bce62cdf34be641096e0628ea133a1d2ce33d4cf35550c6cabddbe3519265644d44bec491bc246d7e1d361c86595b56d1d59fb72baaf6d1919316 SHA512 f96005934b8bc752059106f8caf7df0574f5ef3c7a83bd797497b56ca556a7ff4dc1d28195e421259e82ea027b5c738094add3ec107a22544c9070725d8d46bb
+DIST libXdmcp-1.1.3.tar.bz2 332795 BLAKE2B 0c9df30450857dd2703c4bf54972d5a26c1b6f8e216b4f3173491def650cc32742554eee04c883670e783eb5f476df94ed2c0c52274a51e2bc54d45e5dcb8c77 SHA512 cb1d4650f97d66e73acd2465ec7d757b9b797cce2f85e301860a44997a461837eea845ec9bd5b639ec5ca34c804f8bdd870697a5ce3f4e270b687c9ef74f25ec
EBUILD libXdmcp-1.1.2-r2.ebuild 685 BLAKE2B be687e3a7b1b78fac3c84b45523c3e4ed3f36a1d3c50637adce258e8a3fea4be0b4f13c45ea211f8cf418574bb9280a4f46d886a0a5f4bd050240bd816c12fe1 SHA512 66f7b3772682c81d047c65c670cc0993f111999d041436fb1dcc86400e319be836d49b087a9a600466ad55307e3abe30eb74cbaa779aee205b7bdfe1a70f71e0
+EBUILD libXdmcp-1.1.3.ebuild 674 BLAKE2B f7e58ee61ad88e80ead70a8d3ef3a49e8be5b74a26d40c65bb342acad924aa20222c822bd306129c23e1a60030bd7813615e64e140b8c103dcb7b431358f1b4f SHA512 797a12d5988b854281d2a8b0184b0342cd79f8efc830dc759bc474f846571c73019bf317c3c0b4486cd4d97c6b7d6dd05e9a708f36327cfb10641d7747c5232f
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-libs/libXdmcp/libXdmcp-1.1.3.ebuild b/x11-libs/libXdmcp/libXdmcp-1.1.3.ebuild
new file mode 100644
index 000000000000..d817cd293ef7
--- /dev/null
+++ b/x11-libs/libXdmcp/libXdmcp-1.1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org X Display Manager Control Protocol library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND="elibc_glibc? ( dev-libs/libbsd )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}