summaryrefslogtreecommitdiff
path: root/x11-libs/libXdmcp/libXdmcp-1.1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /x11-libs/libXdmcp/libXdmcp-1.1.3-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'x11-libs/libXdmcp/libXdmcp-1.1.3-r1.ebuild')
-rw-r--r--x11-libs/libXdmcp/libXdmcp-1.1.3-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-libs/libXdmcp/libXdmcp-1.1.3-r1.ebuild b/x11-libs/libXdmcp/libXdmcp-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..dc445429439e
--- /dev/null
+++ b/x11-libs/libXdmcp/libXdmcp-1.1.3-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org X Display Manager Control Protocol library"
+
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+
+RDEPEND="elibc_glibc? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}