summaryrefslogtreecommitdiff
path: root/x11-libs/libXaw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /x11-libs/libXaw
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'x11-libs/libXaw')
-rw-r--r--x11-libs/libXaw/Manifest1
-rw-r--r--x11-libs/libXaw/libXaw-1.0.13-r2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/x11-libs/libXaw/Manifest b/x11-libs/libXaw/Manifest
index de8c4bba0072..302b8e92f2a8 100644
--- a/x11-libs/libXaw/Manifest
+++ b/x11-libs/libXaw/Manifest
@@ -1,3 +1,4 @@
DIST libXaw-1.0.13.tar.bz2 674140 BLAKE2B e141a135d1a45edfb71687951542a31d838bf560997a631b3590db0581f94768a8cc77ebd86c7cff60668e9843b1258a9eb60383a4d25b704ce9dc91fc6d0bdf SHA512 d768a39f7111802493fa1df1b80d858e4139ceeb883d45ff13ce3b7a0e775a7d2834b7ad157c8330117f04c32f38979795332dd7a119adb2344fcb1aa9cf1e2f
EBUILD libXaw-1.0.13-r1.ebuild 876 BLAKE2B f580b1fa6791ea8f0e5444bf7c5a392a155b06e1717165914a0fbfd0c5825d78a9dffc1a8dc85aa0068c3f933679b1823186acea0b4ba2b2f82932d3bd15568c SHA512 daf10e307f9071c9812f5f6661a60bbef1af69bc9685bd7f792d4adc3fce37799be23239beafe1ef9400936e420b366eae76ba39830f247161920374f9363f45
+EBUILD libXaw-1.0.13-r2.ebuild 891 BLAKE2B a6c957321d621974e077e656e62dca3277653bf377775753a4e217ef17473493084209be5edd0f8b4f512e3b54e27763806de5f1b251e22a2d5961ba0d03f1c0 SHA512 51d721e8bb67d93d7aa26f34396a753f99a442f12ac9b0e458e636dbbfebdc6d89028b146288e552be0c49246e6df8fb516a82b6be70c1439376321db3b1e61f
MISC metadata.xml 308 BLAKE2B c8b1bdf11408b82ade3364323648bf367d76ddec0711a46f3662f4fe34aec46918c7acc617a782312725ab0169e82c25d480194a2ff22bc3429f5f3c1d4e434d SHA512 331203494a47823877466669591ec0de413400dc18f51e96c18a06b7bece2fe56a73055cd7f1e4ffcf6cc9cc9bdd488a7a5ce2830def9ce5a6ae187c52dad364
diff --git a/x11-libs/libXaw/libXaw-1.0.13-r2.ebuild b/x11-libs/libXaw/libXaw-1.0.13-r2.ebuild
new file mode 100644
index 000000000000..a7fcece439b2
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.13-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="deprecated"
+
+RDEPEND="x11-base/xorg-proto
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}