summaryrefslogtreecommitdiff
path: root/x11-libs/libXaw3dXft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-05 23:02:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-05 23:02:25 +0000
commit631f7475c7ad33edf25c4120e9f23ca03baf427b (patch)
tree192186a462a5ad4230e783408490946df38030ad /x11-libs/libXaw3dXft
parent6bf575618cf9022e99cbfcc64036fd9db79a749c (diff)
gentoo auto-resync : 05:12:2023 - 23:02:25
Diffstat (limited to 'x11-libs/libXaw3dXft')
-rw-r--r--x11-libs/libXaw3dXft/Manifest2
-rw-r--r--x11-libs/libXaw3dXft/files/libXaw3dXft-1.6.2h-fix-gcc-14.patch17
-rw-r--r--x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h-r1.ebuild44
3 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/libXaw3dXft/Manifest b/x11-libs/libXaw3dXft/Manifest
index 3ea69077c95d..b8f957646406 100644
--- a/x11-libs/libXaw3dXft/Manifest
+++ b/x11-libs/libXaw3dXft/Manifest
@@ -1,3 +1,5 @@
+AUX libXaw3dXft-1.6.2h-fix-gcc-14.patch 733 BLAKE2B 28d8fe2840e298e94b738973cd1a032c359d2893429d5e7fc5e6f4122d19c3c52ab7a3749415f563b42eadd60aa5d8c40e8deef2451ef9ca6f5976b11196d867 SHA512 d44ad4ebf0c5b174751a5b589f77bf58b7c12a9d5997d70732ad70816445d07fa6f1da98d49744b9d5ee9aa955a7cc7b344d4049645e1b6a1bed71262dda781e
DIST libXaw3dXft-1.6.2h.tar.bz2 593436 BLAKE2B e0e5c3a3e5b4564d58bb059ad7eb594d1a46cc37e0e21799ea11892d206a57f3f11a46d7413310d2a43738f03e001f5dc6f8c3b86bbe806fbc651661e9f720db SHA512 bc9b6de80379bdc82c7f5cd46ac78a422282b018eed979ef5548d0382f43e53619a6ebaf40c6b9ae264d597536022dc1daf023c1d1a04e948d4b4658bc6479ca
+EBUILD libXaw3dXft-1.6.2h-r1.ebuild 864 BLAKE2B d1e0360578f6d3c98221b300147bf99aacee8571a44da54547129f254c8fdb785152d732362dfaa72881dd4c59e4c01f745b315f840d2b69e627de50fcdee1ba SHA512 8ccbbad7481ff7cbb20cc6e971967e46eb850b268a5bbf493f423ce559c792d782325d5c57fdcaf8f547e6196d93858520e64286a007cbfaa49501244e770567
EBUILD libXaw3dXft-1.6.2h.ebuild 808 BLAKE2B 8bef6fa1cc7c5a08beae433bc6250bead30d83b354ade086ec436af1149c610d154de1b57580c080525969c1d6bf1bce1ea9cba378c2f3344f93ea9c27dd27e9 SHA512 065f6245e2332c52e2c1afc260c9619a1de6983524a95a8b25d30359ab2ca838c312a958039fbe53abdb6c478208e61c306689f8dc8887e13d74257b7fc33dcc
MISC metadata.xml 328 BLAKE2B 40dfd53b0ddf66b8c03a1c5358d22f67ebc54693ad3cd5fa21f10002814e45d48856aa3e8685db21c72d0f759d93722da73e41ef27f0004565432eae6670a2b6 SHA512 d78dd7fb90d69d9f795cd866b2d3805a3caa446e5cbfc1140e7b32da4031b6aa19aeeefe774761c80d11a6a36a11c3a4455872854477b3634e5f49c5d5eccf0c
diff --git a/x11-libs/libXaw3dXft/files/libXaw3dXft-1.6.2h-fix-gcc-14.patch b/x11-libs/libXaw3dXft/files/libXaw3dXft-1.6.2h-fix-gcc-14.patch
new file mode 100644
index 000000000000..ae69a5dccba1
--- /dev/null
+++ b/x11-libs/libXaw3dXft/files/libXaw3dXft-1.6.2h-fix-gcc-14.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/919239
+
+Fix compilation with gcc 14 [-Wincompatible-pointer-types]
+
+buffer_return is a char* cast to wchar_t* at call site.
+
+--- a/src/XawIm.c
++++ b/src/XawIm.c
+@@ -1522,7 +1522,7 @@
+ if ((vw = SearchVendorShell(inwidg)) && (ve = GetExtPart(vw)) &&
+ ve->im.xim && (p = GetIcTableShared(inwidg, ve)) && p->xic) {
+ if (_Xaw3dXft->encoding == -1)
+- ret = Xutf8LookupString (p->xic, event, buffer_return, bytes_buffer, keysym_return, status_return);
++ ret = Xutf8LookupString (p->xic, event, (char*)buffer_return, bytes_buffer, keysym_return, status_return);
+ else
+ ret = XwcLookupString(p->xic, event, buffer_return, bytes_buffer,
+ keysym_return, status_return);
diff --git a/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h-r1.ebuild b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h-r1.ebuild
new file mode 100644
index 000000000000..114a134a8408
--- /dev/null
+++ b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xorg-3
+
+DESCRIPTION="Xaw3dXft library"
+HOMEPAGE="https://sourceforge.net/projects/sf-xpaint/"
+SRC_URI="https://downloads.sourceforge.net/project/sf-xpaint/${PN,,}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="xpm"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ sys-devel/flex
+ app-alternatives/yacc
+ x11-misc/util-macros"
+
+QA_PKGCONFIG_VERSION="${PV//[!0-9.]}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-gcc-14.patch
+)
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(usev xpm --enable-multiplane-bitmaps)
+
+ --enable-internationalization
+ --enable-arrow-scrollbars
+ --enable-gray-stipples
+ )
+ xorg-3_src_configure
+}