summaryrefslogtreecommitdiff
path: root/x11-libs/libXaw3dXft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-libs/libXaw3dXft
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-libs/libXaw3dXft')
-rw-r--r--x11-libs/libXaw3dXft/Manifest4
-rw-r--r--x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild36
-rw-r--r--x11-libs/libXaw3dXft/metadata.xml9
3 files changed, 47 insertions, 2 deletions
diff --git a/x11-libs/libXaw3dXft/Manifest b/x11-libs/libXaw3dXft/Manifest
index 9f1f09a817c0..cecfd427803c 100644
--- a/x11-libs/libXaw3dXft/Manifest
+++ b/x11-libs/libXaw3dXft/Manifest
@@ -1,3 +1,5 @@
DIST libXaw3dXft-1.6.2d.tar.bz2 584670 BLAKE2B cde040659a90edb50ac5aa374e8ec04442479ae1c06fe3d5b1387bd3e02c1a0b40ff286ad40f0ae7841544d1244648e34905570e5827dc0efe60a62da3261c9a SHA512 ac434b7f055d20ceb0bd17851d8ba69976ec562a60cb8012a259045e52c038278f0a8b25b52a61befab3aa169b74fd919278c671f1b6e282efb404e089772740
+DIST libXaw3dXft-1.6.2h.tar.bz2 593436 BLAKE2B e0e5c3a3e5b4564d58bb059ad7eb594d1a46cc37e0e21799ea11892d206a57f3f11a46d7413310d2a43738f03e001f5dc6f8c3b86bbe806fbc651661e9f720db SHA512 bc9b6de80379bdc82c7f5cd46ac78a422282b018eed979ef5548d0382f43e53619a6ebaf40c6b9ae264d597536022dc1daf023c1d1a04e948d4b4658bc6479ca
EBUILD libXaw3dXft-1.6.2d.ebuild 737 BLAKE2B 7588db2950c7574fb799a1c067ba2ee916a28d473e1dae53f2bd942e437a3565028b3beaccd63a6e4fad7ff13d4f7fdbf71260ee8cc8b26fabb6bfdddb8a7066 SHA512 b2cacfb2d2dc7975d8f5e16b6391a32100b515e656947faceb42203d1455f5e8eec7648515ccf13007bec2b2d2db7db6596a537945b783e01a97decc71038fe9
-MISC metadata.xml 246 BLAKE2B fdb264ea0fcdffe3b15f288ef6958a743a7c88bc85f82e13d20af443e93182007ffcf8ccfd62071b57660a668f9c25753c12baa7a409c9d42a408293c21f482c SHA512 be42da502b805b08126629fdde43bd1473535fc5588faf7c65c05e923736fb18f0249fe61ac5c18c4de1619bd52e4865449d1f02ec19f2c2581f6c2e23a5ed4c
+EBUILD libXaw3dXft-1.6.2h.ebuild 739 BLAKE2B 48f4e4210b98ba309466a206960754f77a4e4f0c02977fd1bcaac2f8013ec462d3f0c52e528877acdd9452086e2f1b7936133b97e295db520b2c3b6d209aecee SHA512 0a746e83ee7b7d4beafb6bbff10eae96535fff2bb6532dd72dc54737c61a312726409b6223b3a264c8abfb7f99db3c5624937410d8ff27332bb4f2c6f3cb76fb
+MISC metadata.xml 481 BLAKE2B 3d867f37532e6b3f0033f9697c7f38a0b39ece17c9e890e309dcc60b80172c4483a411c0e0811efcbd73de4210cdcdbc9d39fea8731e9bd765182ff13aefd336 SHA512 707b9a3ae30cbad1d0b505a9466fa79dc687250887b600beb1b90caa32552bef6354871b3ffe4ab05c3e75f7154ee27681944edeb0b0111d7724e977cf87c5ef
diff --git a/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild
new file mode 100644
index 000000000000..3c771bc204fd
--- /dev/null
+++ b/x11-libs/libXaw3dXft/libXaw3dXft-1.6.2h.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3
+
+DESCRIPTION="Xaw3dXft library"
+HOMEPAGE="https://sourceforge.net/projects/sf-xpaint"
+SRC_URI="mirror://sourceforge/sf-xpaint/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode xpm"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXmu
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable unicode internationalization)
+ $(usex xpm "--enable-multiplane-bitmaps" "")
+ --enable-arrow-scrollbars
+ --enable-gray-stipples
+ )
+ xorg-3_src_configure
+}
diff --git a/x11-libs/libXaw3dXft/metadata.xml b/x11-libs/libXaw3dXft/metadata.xml
index 9809f23e9c1a..9ed9d563686e 100644
--- a/x11-libs/libXaw3dXft/metadata.xml
+++ b/x11-libs/libXaw3dXft/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>ceamac.paragon@gmail.com</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="sourceforge">sf-xpaint</remote-id>
</upstream>