summaryrefslogtreecommitdiff
path: root/x11-libs/libSM
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 07:50:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 07:50:47 +0000
commitef4d67f1907798e309efed58d673fd60594a14a8 (patch)
treede3ad0f65999c31df8a545f5d8918bae816e0a4c /x11-libs/libSM
parent30be4d7d2806b014770312920fcda743d4dc67d0 (diff)
gentoo auto-resync : 20:12:2022 - 07:50:47
Diffstat (limited to 'x11-libs/libSM')
-rw-r--r--x11-libs/libSM/Manifest2
-rw-r--r--x11-libs/libSM/libSM-1.2.4.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-libs/libSM/Manifest b/x11-libs/libSM/Manifest
index 07c3a7990a20..f764db2ea831 100644
--- a/x11-libs/libSM/Manifest
+++ b/x11-libs/libSM/Manifest
@@ -1,3 +1,5 @@
DIST libSM-1.2.3.tar.bz2 362595 BLAKE2B 20b7327cd16e066bd2a81eae60f52cab7499dd92d65786d0e5726faa64c2055376749562ff2158777f83711e1517b90b2dc94670892b787889b3950c0a975b68 SHA512 74c42e27029db78475e62025b4711dbac5e22d2f8e8a24be98a1c31b03c0fc4afe859928f851800ea0b76854f12147900dc4f27bbfd3d8ea45daaaf24b70a903
+DIST libSM-1.2.4.tar.xz 306944 BLAKE2B c1944cd8e25389cffc18e9f6e46e3543381a2d74036cff2c24f063c1defca001c94055ef278dc468123b1f60f145df5daf34bcec39875ad918b664a3c279777a SHA512 7f1d41b7b6c5dd456c49ccad7740c3ba9791a2793fa50fd94814a4164ce2e20c4a0a0ad42a87708e494ed5c23f611be6d3ccd9ef1e9add6d46ac545e2b0f6f86
EBUILD libSM-1.2.3-r1.ebuild 1734 BLAKE2B dda743ea00a43c47cc31f5ab8906f61c55253a7d80ce8063e62151e29994ca7fafeb8fc9d45ca2bed10def369422498e4a3a70f0d3d334fcf03a63b37d104e64 SHA512 fa213a1b1d6ca0e18c6396348c4828d877f5c821fa090025c7bd0fbde28d80b7d1cb0d7fd6b391afd230914021968ac74a303200d9a574a753dd204cbf71962b
+EBUILD libSM-1.2.4.ebuild 1755 BLAKE2B 98a044d3b8abe3746066c91afd01e244deefd8f10c0ab93a603501bf33fc6c09dfa70ccb8f4c0ae5a285acc6d3befccb23b3c0b4432cc27ae8e547446b7f11bb SHA512 87bbe249aff4da17bbd626e5ff186ff7a5d159a34a775a3e4b8279e30971a976852fa4ce186ab46969ac89ab2b59b8fd7b99ef136b32bf796c71c08374e8cd06
MISC metadata.xml 457 BLAKE2B 895411214399309db731cd3f1c5c49ec5a505aa4a7a03e9fc39e7027b1956aeae7b0ffebe1d6f4500eaba907c0aa2ce7332f56de0b53ebc26dd000835a29c9ce SHA512 9e810808a715e91e939d710c5633675d4a7d74b2a18d8054d1932f6022bf186ae981b1ffffd81893bb1959923ddf541908a24656e7c308589994178dbab9ff60
diff --git a/x11-libs/libSM/libSM-1.2.4.ebuild b/x11-libs/libSM/libSM-1.2.4.ebuild
new file mode 100644
index 000000000000..ce89e40f714d
--- /dev/null
+++ b/x11-libs/libSM/libSM-1.2.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Session Management library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="+uuid"
+
+RDEPEND="
+ >=x11-libs/libICE-1.1.0[${MULTILIB_USEDEP}]
+ uuid? (
+ elibc_Darwin? ( sys-libs/native-uuid )
+ !elibc_SunOS? ( !elibc_Darwin? (
+ >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}]
+ ) )
+ )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+
+src_configure() {
+ local withuuid=$(use_with uuid libuuid)
+
+ # do not use uuid even if available in libc (like on FreeBSD)
+ use uuid || export ac_cv_func_uuid_create=no
+
+ if use uuid ; then
+ case ${CHOST} in
+ *-solaris*|*-darwin*)
+ if [[ ! -d ${EROOT}/usr/include/uuid ]] &&
+ [[ -d ${ROOT}/usr/include/uuid ]]
+ then
+ # Solaris and Darwin have uuid provided by the host
+ # system. Since util-linux's version is based on this
+ # version, and on Darwin actually breaks host headers when
+ # installed, we can "pretend" for libSM we have libuuid
+ # installed, while in fact we don't
+ withuuid="--without-libuuid"
+ export HAVE_LIBUUID=yes
+ export LIBUUID_CFLAGS="-I${ROOT}/usr/include/uuid"
+ # Darwin has uuid in libSystem
+ [[ ${CHOST} == *-solaris* ]] && export LIBUUID_LIBS="-luuid"
+ fi
+ ;;
+ esac
+ fi
+
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ ${withuuid}
+ --without-fop
+ )
+ xorg-3_src_configure
+}