summaryrefslogtreecommitdiff
path: root/x11-libs/libSM
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /x11-libs/libSM
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'x11-libs/libSM')
-rw-r--r--x11-libs/libSM/Manifest2
-rw-r--r--x11-libs/libSM/libSM-1.2.3.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/x11-libs/libSM/Manifest b/x11-libs/libSM/Manifest
index 5692e037196e..15d08f5933a2 100644
--- a/x11-libs/libSM/Manifest
+++ b/x11-libs/libSM/Manifest
@@ -1,3 +1,5 @@
DIST libSM-1.2.2.tar.bz2 348908 BLAKE2B f3d6d40bfb3058000fd13e9f5ed8daa6628ef197d737e9186e66a517d4c0d4238fa65d0f922b9e6b2839a6f37344c64a560b126911679315cb3824c814d474c7 SHA512 dfb91dcc7200fce8d0a62953ae4b81fcb00d525674bbcc6dfcaa23ecb35e1213ceb07cc51f590072dce2107909903160d9f3636a0434fe2a605b1e9a9bd0a6ca
+DIST libSM-1.2.3.tar.bz2 362595 BLAKE2B 20b7327cd16e066bd2a81eae60f52cab7499dd92d65786d0e5726faa64c2055376749562ff2158777f83711e1517b90b2dc94670892b787889b3950c0a975b68 SHA512 74c42e27029db78475e62025b4711dbac5e22d2f8e8a24be98a1c31b03c0fc4afe859928f851800ea0b76854f12147900dc4f27bbfd3d8ea45daaaf24b70a903
EBUILD libSM-1.2.2-r2.ebuild 1716 BLAKE2B 929e1c043c04cfda1ee1805cb0db16a120a606628acf25feb09528db7c4bdec0b975398a7a413bd212936292cbde3217c938dde3d0157b57b9389999071ba305 SHA512 5d43444bb8e99a89c79cde615359d7ddf3f326428d8a368282e19f9df4b405ab146040c22c674d4eb5818059aecddb3125484de0e18859c08dd6b8fb20986b09
+EBUILD libSM-1.2.3.ebuild 1724 BLAKE2B 0e815750b78b5bbb11d61f0b21590dbccd39153353994422e3c0fb8e7ee7c07ea57a2d811ab4f863f46420da0bdcfdbe938266f7e3fda772908141452ae4066b SHA512 75845756c00100108153d9e8f702685f99da7c375423799e44c34f7ee85818c139e8db38dd96c84a8ec639be38719fda026b7c7ee41a81f2f51074081f21506a
MISC metadata.xml 348 BLAKE2B 475822d6499e8c44bda145b3fb4d72b0f462c03ddddf44cdfb8359a2b0a0e44917a0004a53ace75218efa01c25491fd66e52c1bc0c7e392c88ba9cdbbe414e54 SHA512 4fa0439dc05b56a6fc0280c020ccbc52438ba0d22a4a9b8c0e4830844fa50bc6af8096498336b0d9752687b6e30dce581a24b4b67a812d2e7a62783e37af86d5
diff --git a/x11-libs/libSM/libSM-1.2.3.ebuild b/x11-libs/libSM/libSM-1.2.3.ebuild
new file mode 100644
index 000000000000..f122e0662537
--- /dev/null
+++ b/x11-libs/libSM/libSM-1.2.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Session Management library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="doc ipv6 +uuid"
+
+RDEPEND="x11-base/xorg-proto
+ >=x11-libs/libICE-1.0.8-r1[${MULTILIB_USEDEP}]
+ x11-libs/xtrans
+ !elibc_FreeBSD? ( !elibc_SunOS? ( !elibc_Darwin? (
+ uuid? ( >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}] )
+ ) ) )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local withuuid=$(use_with uuid libuuid)
+
+ # do not use uuid even if available in libc (like on FreeBSD)
+ use uuid || export ac_cv_func_uuid_create=no
+
+ if use uuid ; then
+ case ${CHOST} in
+ *-solaris*|*-darwin*)
+ if [[ ! -d ${EROOT}usr/include/uuid ]] &&
+ [[ -d ${ROOT}usr/include/uuid ]]
+ then
+ # Solaris and Darwin have uuid provided by the host
+ # system. Since util-linux's version is based on this
+ # version, and on Darwin actually breaks host headers when
+ # installed, we can "pretend" for libSM we have libuuid
+ # installed, while in fact we don't
+ withuuid="--without-libuuid"
+ export HAVE_LIBUUID=yes
+ export LIBUUID_CFLAGS="-I${ROOT}usr/include/uuid"
+ # Darwin has uuid in libSystem
+ [[ ${CHOST} == *-solaris* ]] && export LIBUUID_LIBS="-luuid"
+ fi
+ ;;
+ esac
+ fi
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ ${withuuid}
+ --without-fop
+ )
+ xorg-2_src_configure
+}