summaryrefslogtreecommitdiff
path: root/x11-libs/goffice
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /x11-libs/goffice
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'x11-libs/goffice')
-rw-r--r--x11-libs/goffice/Manifest2
-rw-r--r--x11-libs/goffice/goffice-0.10.50.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index 3add9ffcae98..9838b08d0c06 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1,3 +1,5 @@
DIST goffice-0.10.49.tar.xz 2430256 BLAKE2B 64ef27ab729f02b42742b2ae8da43c59b560d016caa707c6dccb3dc6f23eaab13b40367f145b83b1c728c9884dff164118f4a4d6f9ac5accb07596173b127271 SHA512 a185f9fc814ecd2a6e69d026ac150c38e30e1a440f7640bcfc3bfd1939b924621eabf2faafa2837e2d1835418f5481a0d0d7980f4a669e7ca1b93907b17a303a
+DIST goffice-0.10.50.tar.xz 2430608 BLAKE2B 0b06da8d58c4407465266f8c5421331d5d05731038bca191afdd1823950dde07439d458c0ddb93e0641ff81e727f055313be3c8af29bdf32214ed8b2c2cafc0b SHA512 1117540d9162d45059150281b03941ff9b6df1929dcbd7e5aa6e28010d3bb5a46902c30b6f1d35fd5b60f9afe73b58f132aa686aa1712332ea18635d5a79bd0c
EBUILD goffice-0.10.49.ebuild 1419 BLAKE2B b94d44596297b2ac24076e4021f0a557828fc0a185a9a933d774134ac99411189ccafbe3549b35503d240f82635d1eea9c7ce5b7a6623b5e33ac7895cd1be87b SHA512 ffd5cb7122e6a6b9997bbd3bb7d837061d2e87b0df26c9a823b34a50b35a5e0766302a0f2e56a319e53393f53eeeb57fabd00f3e0333de657afae77564b77c82
+EBUILD goffice-0.10.50.ebuild 1421 BLAKE2B 2deabb9817080a9e684e2d87ed423d1a2921a1a47b1c2a9a50ed6782d2761a8b98b3d0fdec5b70fbdff4fd4442525a29d9f86a44574ca03cad027d1751e1b9ac SHA512 faaa54513d7666a724dc03d6611e6026a21de35f0ca8f94ca05659bd6f671e555448fa9f97b29bfeac1473246e1827c4c14b9ee79df49353433ce14f7662222a
MISC metadata.xml 441 BLAKE2B d1239d813165b887ed43610e0b9a09afd739164ecf52a0b6a94e957550b5dec5e18dbf5777e4b7bf8e1d665edf89bc5777ad90ebd93caeab5af6fc2882eb3469 SHA512 69e822f6c8ecb89ae952b30074c2527e8283eeabe32ac6555d043576b21d0f5a40b968b0211574ce8b1836dac85370070ee86905551bdd8cf2418cdc2ac6c3ce
diff --git a/x11-libs/goffice/goffice-0.10.50.ebuild b/x11-libs/goffice/goffice-0.10.50.ebuild
new file mode 100644
index 000000000000..33a766b3e012
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.50.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org libtool
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libxml2-2.4.12:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=x11-libs/cairo-1.10:=[svg]
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/pango-1.24:=
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ dodoc MAINTAINERS
+
+ find "${ED}" -name '*.la' -delete || die
+}