summaryrefslogtreecommitdiff
path: root/x11-libs/goffice
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /x11-libs/goffice
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'x11-libs/goffice')
-rw-r--r--x11-libs/goffice/Manifest2
-rw-r--r--x11-libs/goffice/goffice-0.10.47.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index f9034f6044cd..f62106d31733 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1,3 +1,5 @@
DIST goffice-0.10.46.tar.xz 2397976 BLAKE2B a05696cde60b1cb1ee915bebd3a6e99d1f0a31dc232481615a1c6bbc05ee5433cdebfb05d96160026b260c752c2cfb11c0aecc338079cda66fd40b653fb8b0d1 SHA512 23714fef4dabccc76fe96b78d8eba9c9adb01cb9b3e2f1a9768598fb2a82742b2d2060a7d2548279998488c59e313d7a5863a96b2eb380f540b61fb08e0330f3
+DIST goffice-0.10.47.tar.xz 2400616 BLAKE2B 16a92b3aa5c6e53cb0fe3f51d3ce03a9df6a18f50c0d6890da6ca2529f9e90e3ba30bef63b3c840697d229f58a723957731f985bf02ba80ec4d63bc93d6b7c1a SHA512 0db26fbd049893ee9274ee492e1dc3f10ae789cf99cc0b9dda3f1c2f106423e4679cc56515eb08bbf752aaf48492212777eee08d43a9fefb0b22048e883f5a76
EBUILD goffice-0.10.46.ebuild 1433 BLAKE2B 27245a4417af2d02a716e2a1d15150e51cec6ff313bf3e71672fa9c65bba7002f5caaa43ced59f322ed22e8ae50b98ffebadff79e6acbae18e1636c38dea5c9b SHA512 2e86d28586e2fc09a316f601d123d6dafbc3f66be7a933d3560584ac0474bc773f5d63bbf1e0dd25bd8052aacaa5202a3c1f02ff1df221c71703eee0ef01c655
+EBUILD goffice-0.10.47.ebuild 1435 BLAKE2B 21b3248acb696e0110696071828797afe67d49952a4a3a43acef2c016eea09020309837cb8ce418c19a0a345721614b57f56da5ccf971a4fcdcfef7b806412d3 SHA512 992c2f665ee577dd8b459f7e2b7a83c720c4150ce9e5ee9b7f5639fbcb7feeb14c0549bc9040995c0f9f0e21c558273872de9d62c015597a5befb791d411ea2d
MISC metadata.xml 441 BLAKE2B d1239d813165b887ed43610e0b9a09afd739164ecf52a0b6a94e957550b5dec5e18dbf5777e4b7bf8e1d665edf89bc5777ad90ebd93caeab5af6fc2882eb3469 SHA512 69e822f6c8ecb89ae952b30074c2527e8283eeabe32ac6555d043576b21d0f5a40b968b0211574ce8b1836dac85370070ee86905551bdd8cf2418cdc2ac6c3ce
diff --git a/x11-libs/goffice/goffice-0.10.47.ebuild b/x11-libs/goffice/goffice-0.10.47.ebuild
new file mode 100644
index 000000000000..12d2ce5eb098
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.47.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org libtool
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libxml2-2.4.12:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=x11-libs/cairo-1.10:=[svg]
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/pango-1.24:=
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ dodoc MAINTAINERS
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
+}