summaryrefslogtreecommitdiff
path: root/x11-libs/goffice
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /x11-libs/goffice
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'x11-libs/goffice')
-rw-r--r--x11-libs/goffice/Manifest2
-rw-r--r--x11-libs/goffice/goffice-0.10.52.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index e85a414da746..52cb88b951e6 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1,3 +1,5 @@
DIST goffice-0.10.51.tar.xz 2432992 BLAKE2B 89da3c4707516884c13fed15f3ea04a60f871888469c7a119d42654f1470001bbcbc5a67bd46fcdb6af458ded0cb951a132cc60cd7861d6ebb762bdab1cf4311 SHA512 4d0e6c4c4c6c2f18b1e22c2b24d4034a693c1f6698e58589b83a956b9ff52d1ce05f1e7fdaab5c22c8c6f1d93b53c202f2505bdf9fddba646ef34c75fdb2f520
+DIST goffice-0.10.52.tar.xz 2436944 BLAKE2B 13c2d28cd9bd081d4636325e3df14193d5ffad913f4f9fa78251d848f293eeca5ee265058b2c9662b5bd48957b39f31714eb41469f3228359dba1923f918bea5 SHA512 8636bdfd436a0b5853aead6ecf09ae39c5059b2d9044cf04c9f2e0f4d2572aaa07e51cfd123b0dd153877d1c0d5f4af78a031d63b03c724bf1e8282d2e1cc841
EBUILD goffice-0.10.51.ebuild 1426 BLAKE2B c26a2b63209d72e576da5e60899e2e30351530a819e060d6adb5451660a1d5557b5a511030d7bffabf106d7dfe843b391b71b361c4691a00b515e58533daedca SHA512 97e0490875f3698a4405cc203fa87a7eaa3c7e336f6d71bb7de0cf411e24afc59a304fab9d45f9c16952af6f77269c3296fb6525cc97002a99e7432806d8a1dd
+EBUILD goffice-0.10.52.ebuild 1427 BLAKE2B 3524f72f80da0d858b23d8598d34d4b987b49d73bc33990489634696266471eb8332d9fceaf0af0ba477efe05b0271efddb8d7115e621be2e9fb4eb410888809 SHA512 7d3d4b895e36936e05c126861993f529fe84236deb6ede9426f80ee4b1439d0f672dbead9b619c550b0efb7a11120b9dbb7556efa0fb03fee6607b04c311df49
MISC metadata.xml 547 BLAKE2B d4d95fec4ee5b452af722544aeab368219ecd832def2458af565639cbed6e37807a8fd54dc388070bef89f6f277ac323f27cc397f9b469f60e02e001e12a91fb SHA512 b5b72cea3a76b2ce768510f32e7e4ac77a4af086671304a52f19897c54a3e8af1f36b625e590498bbb51da5c267af66ed979c8a27d9e0d6c4f4bfc7f78390326
diff --git a/x11-libs/goffice/goffice-0.10.52.ebuild b/x11-libs/goffice/goffice-0.10.52.ebuild
new file mode 100644
index 000000000000..2bcc131cd893
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.52.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org libtool
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libxml2-2.4.12:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=x11-libs/cairo-1.10:=[svg]
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ >=x11-libs/pango-1.24:=
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}
+
+src_install() {
+ default
+ dodoc MAINTAINERS
+
+ find "${ED}" -name '*.la' -delete || die
+}