summaryrefslogtreecommitdiff
path: root/x11-libs/goffice
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-08 14:01:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-08 14:01:34 +0100
commit4645b6f17f0da81e9fe84081fb126a37102ba153 (patch)
treee6c48cf3db2213af38cf528a5364fffd5c74c6d6 /x11-libs/goffice
parentebce8994fe3cc4ca9fbc96ca837cb4c4e98adcbd (diff)
gentoo resync : 08.05.2018
Diffstat (limited to 'x11-libs/goffice')
-rw-r--r--x11-libs/goffice/Manifest2
-rw-r--r--x11-libs/goffice/goffice-0.10.40.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
index 0e60b2e6e046..1f2e05ed78b5 100644
--- a/x11-libs/goffice/Manifest
+++ b/x11-libs/goffice/Manifest
@@ -1,3 +1,5 @@
DIST goffice-0.10.38.tar.xz 2373308 BLAKE2B f270233adbbf300ad41516b1ed988db0772b95940196a6ac92c3090f6e52bc47933bb6bb4c023d7137cbca42adfab17fc41b82042c2e9c0340a6cd84942874e5 SHA512 1d72e30ee0b9f322cd4114d0a024a99e6d9ff7efcaeb9ca40b5fffe94180c232f03935743c15b1c6170f8bfc04fea5bdcc4d12760643c66cffafefbaa562fd62
+DIST goffice-0.10.40.tar.xz 2381416 BLAKE2B 24d1905e41e1eb57be53f8f7598776457a17707412e79f2e314e9d1bdbea97a406b1ec27ee628f7d50e22305cd41d900a588520d2995f8be61021ae9b7de60d7 SHA512 1756ab825afe0d4a6249c351b2713b5397827bf289d1c2af5a6a6ccc21797ff01d8b69c72d83c9d8b941d5c73ad03bbf63bd98e475828787d8bbf8d18ffd0ede
EBUILD goffice-0.10.38.ebuild 1236 BLAKE2B c76bcf2963ca520fe37ad8b6ba768f3783cde1f764dc8ed6992dae2ba179607a45da2f67ec856980924a62cb7e52c03c5d99da530b3aaf393e6ab55310522ff0 SHA512 7746c69bd8dbb68e207592897711e445f45cc6995452d6b128db24532ec21004fcdd95863561899d78278dc951338d0c6774760eb065249112342ae3ffa95b81
+EBUILD goffice-0.10.40.ebuild 1238 BLAKE2B 3434874fabc86dcaa1b79cbad84b36bc05a75e8d94712c6371ebc19ade6cabfa5523d43eba61e8111d44ec74969d5304aeb1796cdcd7be86f95b941db3bbe856 SHA512 8b212594e4f47b06fb46d086f702acdb89d2968688ebb0865e8e59d5a9d1d2dead48e6e5d6cc037bde5f073f69f858709abc218363a65f4f0068deacd2731def
MISC metadata.xml 441 BLAKE2B d1239d813165b887ed43610e0b9a09afd739164ecf52a0b6a94e957550b5dec5e18dbf5777e4b7bf8e1d665edf89bc5777ad90ebd93caeab5af6fc2882eb3469 SHA512 69e822f6c8ecb89ae952b30074c2527e8283eeabe32ac6555d043576b21d0f5a40b968b0211574ce8b1836dac85370070ee86905551bdd8cf2418cdc2ac6c3ce
diff --git a/x11-libs/goffice/goffice-0.10.40.ebuild b/x11-libs/goffice/goffice-0.10.40.ebuild
new file mode 100644
index 000000000000..9bf3bf394d80
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.40.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="https://git.gnome.org/browse/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24:=
+ >=x11-libs/cairo-1.10:=[svg]
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.20:3
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/perl-Compress-Raw-Zlib
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}