summaryrefslogtreecommitdiff
path: root/x11-libs/fox-wrapper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /x11-libs/fox-wrapper
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'x11-libs/fox-wrapper')
-rw-r--r--x11-libs/fox-wrapper/Manifest2
-rw-r--r--x11-libs/fox-wrapper/files/fox-wrapper-2.sh75
-rw-r--r--x11-libs/fox-wrapper/fox-wrapper-2.ebuild26
3 files changed, 0 insertions, 103 deletions
diff --git a/x11-libs/fox-wrapper/Manifest b/x11-libs/fox-wrapper/Manifest
index bdae18d786ac..a76b775d7e01 100644
--- a/x11-libs/fox-wrapper/Manifest
+++ b/x11-libs/fox-wrapper/Manifest
@@ -1,5 +1,3 @@
-AUX fox-wrapper-2.sh 1905 BLAKE2B 1b437efc5d8fa8b4d12ccd84469b1c6b8c19cad06fafcdca19304f352edb97e645815411a49ff1aeea1347b3ad024b40bacb761727d32c1d2692e2d5a040f893 SHA512 9cf96c083ea0d787992f40c5acce69dec162535122d65788aa05fe4bf33473103c889a1de98dfd80526c4a53e684cf536105f88bd610e9e50a55eb68bc2ecf35
AUX fox-wrapper-3.sh 1901 BLAKE2B 20b6ca94deee62464642e5a7e127c78135dc83a5c8c4d369fe35d7e6c2686b825b7fe966998f58dbd7bd5d77ae30a9f6e98d1bac46bb06050cf52a1d8c9f30fb SHA512 19d7115feb5566ae8e3c7af9a88aca7d0643dab92fb8bfbdd0bfa826f7357b2caff436741218eb9d51164fcdf863c3150526108e3282fa244102bd85f8abaee5
-EBUILD fox-wrapper-2.ebuild 538 BLAKE2B 50f8f178e5b97c2c54636bfe82a89cfc2274d24d9671a554d3214a7800e7eccf0fe929bb71e737f85aa7f39a078eba4c0a8059d3c686af30347e4f6e60c25b0a SHA512 9de8fa442bc1de861dffb6ee378ccf323f189a1056a027a52aa444bf31dc174b818dd0dbe68af961c9d13cbafa3f6d82c658dc15b369e2e4d36278088eace953
EBUILD fox-wrapper-3.ebuild 550 BLAKE2B 6b75fbb550f8f0c9da9c21619d55f0bf2dc51e4fdb575b0246e7bd3f1f6c419b5c00cb5250df6c4bee3303ba294658e297664e94b68a60fd5ced5a84d5351584 SHA512 d218ecbaec29a6018d00a666679e20ff98c41a512af88a85de5fe89af9f94729fe5512b69e71b14ff0cf67a3d05943b024f966c618f15493f17898eadbcc37d2
MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/x11-libs/fox-wrapper/files/fox-wrapper-2.sh b/x11-libs/fox-wrapper/files/fox-wrapper-2.sh
deleted file mode 100644
index 19d09b5b9ca6..000000000000
--- a/x11-libs/fox-wrapper/files/fox-wrapper-2.sh
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Based on the am-wrapper.sh script (sys-devel/automake-wrapper-1-r1)
-#
-# Executes the correct fox-config version, based on the value of WANT_FOX.
-# All versions of fox after 1.0.x ship with a fox-config script
-#
-#
-# Stable branches first, in descending order, then unstable branches.
-# After a new stable branch, prepend the new version and bump (or remove)
-# the last unstable branch
-#
-vers="1.6 1.4 1.2 1.5"
-bindir=/usr/bin
-
-if [ "${0##*/}" = "fox-wrapper.sh" ] ; then
- echo "fox-wrapper: Don't call this script directly, use fox-config instead" >&2
- exit 1
-fi
-
-if [ -z "${WANT_FOX}" ] ; then
- echo "fox-wrapper: Set the WANT_FOX variable to the desired version of fox, e.g.:" >&2
- echo " WANT_FOX=\"1.2\" fox-config $@"
- exit 1
-fi
-
-for v in ${vers} ; do
- eval binary_${v/./_}="fox-${v}-config"
-done
-
-#
-# Check the WANT_FOX setting
-#
-for v in ${vers} x ; do
- if [ "${v}" = "x" ] ; then
- echo "fox-wrapper: WANT_FOX was set to an invalid version ${WANT_FOX}" >&2
- echo " Valid values of WANT_FOX are: ${vers// /, }"
- exit 1
- fi
-
- if [ "${WANT_FOX}" = "${v}" ] ; then
- binary="binary_${v/./_}"
- binary="${!binary}"
- break
- fi
-done
-
-if [ "${WANT_FOXWRAPPER_DEBUG}" ] ; then
- echo "fox-wrapper: DEBUG: WANT_FOX is set to ${WANT_FOX}" >&2
- echo "fox-wrapper: DEBUG: will execute <$binary>" >&2
-fi
-
-#
-# for further consistency
-#
-for v in ${vers} ; do
- mybin="binary_${v/./_}"
- if [ "${binary}" = "${!mybin}" ] ; then
- export WANT_FOX="${v}"
- fi
-done
-
-#
-# Now try to run the binary
-#
-if [ ! -x "${bindir}/${binary}" ] ; then
- echo "fox-wrapper: $binary is missing or not executable." >&2
- echo " Please try emerging the correct version of fox, i.e.:" >&2
- echo " emerge '=x11-libs/${binary/-config/}*'" >&2
- exit 1
-fi
-
-"$binary" "$@"
diff --git a/x11-libs/fox-wrapper/fox-wrapper-2.ebuild b/x11-libs/fox-wrapper/fox-wrapper-2.ebuild
deleted file mode 100644
index eeb9dd5e6bac..000000000000
--- a/x11-libs/fox-wrapper/fox-wrapper-2.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="wrapper for fox-config to manage multiple versions"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-
-S=${WORKDIR}
-
-src_install() {
- exeinto /usr/lib/misc
- newexe "${FILESDIR}"/fox-wrapper-${PV}.sh fox-wrapper.sh
-
- dodir /usr/bin
- dosym ../lib/misc/fox-wrapper.sh /usr/bin/fox-config
-}