summaryrefslogtreecommitdiff
path: root/x11-libs/fltk/fltk-1.3.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /x11-libs/fltk/fltk-1.3.9999.ebuild
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'x11-libs/fltk/fltk-1.3.9999.ebuild')
-rw-r--r--x11-libs/fltk/fltk-1.3.9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/x11-libs/fltk/fltk-1.3.9999.ebuild b/x11-libs/fltk/fltk-1.3.9999.ebuild
index 4171029d334a..f5904db08e28 100644
--- a/x11-libs/fltk/fltk-1.3.9999.ebuild
+++ b/x11-libs/fltk/fltk-1.3.9999.ebuild
@@ -2,10 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools fdo-mime flag-o-matic git-r3 multilib-minimal
+inherit autotools flag-o-matic git-r3 xdg-utils multilib-minimal
DESCRIPTION="C++ user interface toolkit for X and OpenGL"
-HOMEPAGE="http://www.fltk.org/"
+HOMEPAGE="https://www.fltk.org/"
EGIT_REPO_URI="https://github.com/fltk/fltk"
EGIT_OVERRIDE_BRANCH_FLTK_FLTK="branch-1.3"
@@ -123,7 +123,9 @@ multilib_src_configure() {
--enable-xdbe \
--enable-xfixes \
--includedir=${FLTK_INCDIR} \
- --libdir=${FLTK_LIBDIR}
+ --libdir=${FLTK_LIBDIR} \
+ DSOFLAGS="${LDFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
}
multilib_src_compile() {
@@ -190,9 +192,11 @@ multilib_src_install_all() {
}
pkg_postinst() {
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
}