summaryrefslogtreecommitdiff
path: root/x11-libs/cairo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-31 21:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-31 21:02:55 +0000
commitd36c5f9e59f92a021c987989cd79d44460e0da42 (patch)
tree2504c88d1f287ac3a71ebc56e5d19f34a2c1b9a4 /x11-libs/cairo
parente860dfa5acdb67f8e2b8938b005dbaaaaf2c984a (diff)
gentoo auto-resync : 31:01:2023 - 21:02:55
Diffstat (limited to 'x11-libs/cairo')
-rw-r--r--x11-libs/cairo/Manifest3
-rw-r--r--x11-libs/cairo/cairo-1.17.6-r1.ebuild82
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild22
3 files changed, 86 insertions, 21 deletions
diff --git a/x11-libs/cairo/Manifest b/x11-libs/cairo/Manifest
index bbd01d7cd08b..8ffc58865e7e 100644
--- a/x11-libs/cairo/Manifest
+++ b/x11-libs/cairo/Manifest
@@ -1,5 +1,6 @@
AUX cairo-respect-fontconfig.patch 538 BLAKE2B 7cc137277ccb2e1d641fd8ca39ee7ccd0fd4981a07a25122387c2f1b6ca4cd89a830360357953706dee62e4233126cd0630e4622f0682f6782cd27fa31f20ecc SHA512 4d4d473f956b56f11b31f513de06751dcc77342e0f04ecf37064a74b8217f9d3536c0a8a41b09e580f34576ff2d06815b4cbc2bc091c201f947965509677415e
DIST cairo-1.17.6.tar.bz2 43700076 BLAKE2B 05ac766d33e9bdfc5df0347e9a80611554d64886715d1620fbe6f05f36f0134e46e1e6107738d260b380fab5ef2ac609922dce9ebcac01234710d8e2a76e9724 SHA512 1537b34ca49b853f4f60a7ceac0c1b878e7e2874f1ca3a37ab6ccbb704a37872314447016ad07b82312b302bb6df86b71265232a802ccdb9fb8cd18f211ff185
+EBUILD cairo-1.17.6-r1.ebuild 2382 BLAKE2B b8f4df85966a21baa6bb29f18f8f969e2a839b79aa9dd7513a497341e7ae6ad518f297094f3cec4a74bf24af910421ecec23f16be6f4c4ae97e0d923aad4c861 SHA512 1f69ef6585c3e33deef78806fc35fa35fb39e56d7eadc39b6c92e831a8f18ad69eb026e13fe0d313b5e2205e8de2e8ccd39ba509847e32e5a8625fad8e1905b7
EBUILD cairo-1.17.6.ebuild 2835 BLAKE2B 6d3239007d7bfa930aef8921756a95f68fafc4e316d48c9e65333313779f8fdb9839505dac7067869511b2f81336dbba254f8c2b366ddcb2f3937c809a3666c8 SHA512 a8195ce1e421200eca17618fcd768697ae78910deae20e97e8644cb1476ca1dd82979d8835902bd5a870855d099e98123fa8318fbf2e0ec819ab539bce9b52ea
-EBUILD cairo-9999.ebuild 2843 BLAKE2B a123d14d1e6cfbe5828662026ce2da1fd2a63a9e545f6abb05038d4b078e934706cb645851595fdd793542615155f74190d32864b0acbd498e86e3023eb04ceb SHA512 455855ba076c41cc60b819c76e77faea4a35b00a91f36ce2b8531f0acdc821f0d0def76fd79edfe6b9ade345744c9786786081295be2fd1d307bd07376f693c7
+EBUILD cairo-9999.ebuild 2382 BLAKE2B b8f4df85966a21baa6bb29f18f8f969e2a839b79aa9dd7513a497341e7ae6ad518f297094f3cec4a74bf24af910421ecec23f16be6f4c4ae97e0d923aad4c861 SHA512 1f69ef6585c3e33deef78806fc35fa35fb39e56d7eadc39b6c92e831a8f18ad69eb026e13fe0d313b5e2205e8de2e8ccd39ba509847e32e5a8625fad8e1905b7
MISC metadata.xml 781 BLAKE2B 93cef84890039f9bbf75544a857cf611b3444fed5f82611d0f180de9c0df4ec5ea468b569cf99d158135354bec1d06c3aab97e139840db7e18d2b0b8ce350731 SHA512 c8008c604fa8956301078eced6c2c355f0205d9fcdfae68da39b1019fa54724239c713cbbd5f44f3d4d1b4d4d21a75248a00e7da4adffbb1974b6c2d36a30ee7
diff --git a/x11-libs/cairo/cairo-1.17.6-r1.ebuild b/x11-libs/cairo/cairo-1.17.6-r1.ebuild
new file mode 100644
index 000000000000..4803af7d4c3d
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.17.6-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/cairo/cairo.git"
+ SRC_URI=""
+else
+ SRC_URI="https://gitlab.freedesktop.org/cairo/cairo/-/archive/${PV}/cairo-${PV}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="https://www.cairographics.org/ https://gitlab.freedesktop.org/cairo/cairo"
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+IUSE="X aqua debug +glib gtk-doc test"
+RESTRICT="!test? ( test ) test" # Requires poppler-glib, which isn't available in multilib
+
+RDEPEND="
+ >=dev-libs/lzo-2.06-r1:2[${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1:2[png,${MULTILIB_USEDEP}]
+ >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/pixman-0.36[${MULTILIB_USEDEP}]
+ debug? ( sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-respect-fontconfig.patch
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dfontconfig=enabled
+ -Dfreetype=enabled
+ -Dpng=enabled
+ $(meson_feature aqua quartz)
+ $(meson_feature X tee)
+ $(meson_feature X xcb)
+ $(meson_feature X xlib)
+ -Dxlib-xcb=disabled
+ -Dxml=disabled
+ -Dzlib=enabled
+
+ $(meson_feature test tests)
+
+ -Dgtk2-utils=disabled
+
+ $(meson_feature glib)
+ -Dspectre=disabled # only used for tests
+ $(meson_feature debug symbol-lookup)
+
+ $(meson_use gtk-doc gtk_doc)
+ )
+
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/cairo || die
+ mv "${ED}"/usr/share/gtk-doc/{html/cairo,cairo/html} || die
+ rmdir "${ED}"/usr/share/gtk-doc/html || die
+ fi
+}
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
index 74987be53131..4803af7d4c3d 100644
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ b/x11-libs/cairo/cairo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,11 +18,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="https://www.cairographics.org/ https://gitlab.freedesktop.org/cairo/cairo"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-IUSE="X aqua debug gles2-only gles3 +glib gtk-doc opengl test"
-REQUIRED_USE="
- gles2-only? ( !opengl )
- gles3? ( gles2-only )
-"
+IUSE="X aqua debug +glib gtk-doc test"
RESTRICT="!test? ( test ) test" # Requires poppler-glib, which isn't available in multilib
RDEPEND="
@@ -33,9 +29,7 @@ RDEPEND="
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
>=x11-libs/pixman-0.36[${MULTILIB_USEDEP}]
debug? ( sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}] )
- gles2-only? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
- opengl? ( >=media-libs/mesa-9.1.6[egl(+),X(+),${MULTILIB_USEDEP}] )
X? (
>=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
@@ -74,18 +68,6 @@ multilib_src_configure() {
$(meson_use gtk-doc gtk_doc)
)
- if use opengl; then
- emesonargs+=(-Dgl-backend=gl)
- elif use gles2-only; then
- if use gles3; then
- emesonargs+=(-Dgl-backend=glesv3)
- else
- emesonargs+=(-Dgl-backend=glesv2)
- fi
- else
- emesonargs+=(-Dgl-backend=disabled)
- fi
-
meson_src_configure
}