summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-r128
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
commit1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (patch)
treec99a472cce74148d499f42ada873454b0e32a42d /x11-drivers/xf86-video-r128
parentda6a52f691ef980bab92d003d5df8f463c623af8 (diff)
gentoo resync : 13.03.2018
Diffstat (limited to 'x11-drivers/xf86-video-r128')
-rw-r--r--x11-drivers/xf86-video-r128/Manifest3
-rw-r--r--x11-drivers/xf86-video-r128/files/xf86-video-r128-6.10.2-fix-stdint_h.patch11
-rw-r--r--x11-drivers/xf86-video-r128/xf86-video-r128-6.10.2.ebuild14
3 files changed, 25 insertions, 3 deletions
diff --git a/x11-drivers/xf86-video-r128/Manifest b/x11-drivers/xf86-video-r128/Manifest
index bf72efb7088b..d02e3b02ddd6 100644
--- a/x11-drivers/xf86-video-r128/Manifest
+++ b/x11-drivers/xf86-video-r128/Manifest
@@ -1,3 +1,4 @@
+AUX xf86-video-r128-6.10.2-fix-stdint_h.patch 194 BLAKE2B fd054df8e84c8db45c054b6405fb6414d56045461183e49a7bf8d5ca1bc7ed6dea50c5de9bb9893491d5607a4288725527f0532d2a194ccfc5d5bfd8b9446f40 SHA512 fb494532052ba73cabe52d8ac9990a994067f55f9dd56f39edd923bb5f4f2fbbd16333b3c1e5820135f21cb79a6b12745b2fd769df0317c1126ccdc1d6dbb9d6
DIST xf86-video-r128-6.10.2.tar.bz2 504031 BLAKE2B 3d74d0aa82167f8e883b0a92e6d57cf688f36a45971b03327a2fb8171133fc155cd0f233b854f3c3f9713b478c1ac2cb0b4cac124d49431c8429a954a71c68dd SHA512 564b65454ee538c1b9dc5d22a52a57bdff0c1f94e1832719a8310699cee7167c1ca8fcd26243dfc4089832b1fcbab9efafb69c9061b328532f689d02a0acac23
-EBUILD xf86-video-r128-6.10.2.ebuild 413 BLAKE2B 8083d86260b8df7b244fd1db0729545de1270745a52b1dfd17d6582fb6e962bcfb43117748796d415d093066aa08555914e7bf54cd31879bfba2440c173443bb SHA512 fbdb1b93ba88f1e698200f71d054efcd902c5e3b53090b9d980047955e5369bdf4182a32895c6bf67e5f808aafa49ca8453bffa64d88a8de5835acff425bd89c
+EBUILD xf86-video-r128-6.10.2.ebuild 576 BLAKE2B f06b52058b47d8beafa75e47d32c08d77c65a9c8aba7f9fb4c6bd442447df926c53140dfd1bac012cd06af357b33c5fa588f6cb30bfda88184c80fb1a4a0b6fc SHA512 d8eee58f13fe73efbb8f2ce728f124c34fbfb8ba1be01eef9a2128a3fe27e4d41a91c5cf8549f2737b586a641ed78765ef6d2537b390638c1f60a1232f209601
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-drivers/xf86-video-r128/files/xf86-video-r128-6.10.2-fix-stdint_h.patch b/x11-drivers/xf86-video-r128/files/xf86-video-r128-6.10.2-fix-stdint_h.patch
new file mode 100644
index 000000000000..e5b731660632
--- /dev/null
+++ b/x11-drivers/xf86-video-r128/files/xf86-video-r128-6.10.2-fix-stdint_h.patch
@@ -0,0 +1,11 @@
+--- a/src/atipcirename.h
++++ b/src/atipcirename.h
+@@ -29,6 +29,8 @@
+ #ifndef ATIPCIRENAME_H
+ #define ATIPCIRENAME_H
+
++#include <stdint.h>
++
+ enum region_type {
+ REGION_MEM,
+ REGION_IO
diff --git a/x11-drivers/xf86-video-r128/xf86-video-r128-6.10.2.ebuild b/x11-drivers/xf86-video-r128/xf86-video-r128-6.10.2.ebuild
index 6bab28438f22..6369cbf866a1 100644
--- a/x11-drivers/xf86-video-r128/xf86-video-r128-6.10.2.ebuild
+++ b/x11-drivers/xf86-video-r128/xf86-video-r128-6.10.2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
XORG_DRI=dri
-inherit xorg-2
+
+inherit flag-o-matic xorg-2
DESCRIPTION="ATI Rage128 video driver"
@@ -13,8 +14,17 @@ IUSE="dri"
RDEPEND=">=x11-base/xorg-server-1.2"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-fix-stdint_h.patch )
+
pkg_setup() {
XORG_CONFIGURE_OPTIONS=(
$(use_enable dri)
)
}
+
+src_configure() {
+ # always use C11 semantics
+ append-cflags -std=gnu11
+
+ xorg-2_src_configure
+}