summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-nouveau
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /x11-drivers/xf86-video-nouveau
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'x11-drivers/xf86-video-nouveau')
-rw-r--r--x11-drivers/xf86-video-nouveau/Manifest3
-rw-r--r--x11-drivers/xf86-video-nouveau/files/xf86-video-nouveau-1.0.17-xorg-server-API-rename.patch52
-rw-r--r--x11-drivers/xf86-video-nouveau/xf86-video-nouveau-1.0.17.ebuild4
3 files changed, 58 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-nouveau/Manifest b/x11-drivers/xf86-video-nouveau/Manifest
index 088fa2a5dfb4..49c617c62523 100644
--- a/x11-drivers/xf86-video-nouveau/Manifest
+++ b/x11-drivers/xf86-video-nouveau/Manifest
@@ -1,3 +1,4 @@
+AUX xf86-video-nouveau-1.0.17-xorg-server-API-rename.patch 1590 BLAKE2B 930c5b4a5d22f45c3a64bf3332bab683e176917adb6634517e1b1f00e2faef428ce52e48a45481e2f0f3277cef8dca327ddf7915f1b41bbd58cc1ab0b25e68ad SHA512 c2c221b9defe175290a5f76bea6aacc671deefd1d292888e7ce1bc8dbdd598e37191e775d9b4b044183f8eb62219ec86a09144df79989e2a714f26ea825c422a
DIST xf86-video-nouveau-1.0.17.tar.bz2 632535 BLAKE2B 8f4a3e749dbf46f6723f65b7bdffdf32e40fb194a18cb9951af297d7c3bcc34cc4ee6eed4687c42a385c259f37d1438ca7c9eda7594a3426704b358e1cda36fb SHA512 adba58ba5298d1a5b3f9f8540f9ef2cb2e10e47bba8e374103ec2e1f92e915f5f4393ed0021168cd649646e12315135a1efcdf77e8fb1648e1295914d87279b2
-EBUILD xf86-video-nouveau-1.0.17.ebuild 619 BLAKE2B b9b60840274196d73ed5677e47ecd8b4836232dc4226d66f41d0d9e7fccd614ecc2526ba61b077d7a0d407d32faf233bcef1043d9ca3f881b5a68bb712e8bc40 SHA512 62cdcea4973125103e009980a65751baaf1a45805c8c1f19da1b7648b1d05a79544c5a60400723562733b4af87f9a67e343c18751f0d4d98f9ed6ce0762637f3
+EBUILD xf86-video-nouveau-1.0.17.ebuild 681 BLAKE2B 1d90a6a6f5bc370456651edecf0923c75f3587de37f4de03a72a73d259f367757d0614a233c1997b5bee911f3d85889337a0c07d6ff39ecc2d2b66f8640cd83c SHA512 e38c8ec663cb3abfc9526a77a06aa401d70a3be7e483dc0defe99f0871862fea4fd580c4f5c155198c8e3aa39fc4312b3943ca1c38a0e687882534106787541b
MISC metadata.xml 231 BLAKE2B 6373a9c04316f777f87754fbb7cbc856493138d32bdb05d1015946ebbb359c4b8adb9372554097833d5c9a20e00e32fa0a1c90995d9299dd2215a2cadcccbb73 SHA512 bf6ad5078a6775cd61d257939d41ec53d006124475da2949c55b4b3ac138ec85a88b9068c5920b1e781fadda963939b8f120f8864d82e10cf50e09cc8052a6dc
diff --git a/x11-drivers/xf86-video-nouveau/files/xf86-video-nouveau-1.0.17-xorg-server-API-rename.patch b/x11-drivers/xf86-video-nouveau/files/xf86-video-nouveau-1.0.17-xorg-server-API-rename.patch
new file mode 100644
index 000000000000..cb9b6e0f4eec
--- /dev/null
+++ b/x11-drivers/xf86-video-nouveau/files/xf86-video-nouveau-1.0.17-xorg-server-API-rename.patch
@@ -0,0 +1,52 @@
+https://cgit.freedesktop.org/nouveau/xf86-video-nouveau/commit/?id=e80e73ced69b15662103d0fd6837db4ce6c6eb5b
+https://bugs.gentoo.org/827878
+
+From: Dave Airlie <airlied@redhat.com>
+Date: Mon, 13 Jul 2020 09:20:15 +1000
+Subject: nouveau: fixup driver for new X server ABI
+
+--- a/src/compat-api.h
++++ b/src/compat-api.h
+@@ -102,4 +102,8 @@
+
+ #endif
+
++#if ABI_VIDEODRV_VERSION < SET_ABI_VERSION(25, 2)
++#define secondary_dst slave_dst
++#endif
++
+ #endif
+--- a/src/nouveau_exa.c
++++ b/src/nouveau_exa.c
+@@ -157,7 +157,7 @@ nouveau_exa_destroy_pixmap(ScreenPtr pScreen, void *priv)
+
+ #ifdef NOUVEAU_PIXMAP_SHARING
+ static Bool
+-nouveau_exa_share_pixmap_backing(PixmapPtr ppix, ScreenPtr slave, void **handle_p)
++nouveau_exa_share_pixmap_backing(PixmapPtr ppix, ScreenPtr secondary, void **handle_p)
+ {
+ struct nouveau_bo *bo = nouveau_pixmap_bo(ppix);
+ struct nouveau_pixmap *nvpix = nouveau_pixmap(ppix);
+--- a/src/nv_driver.c
++++ b/src/nv_driver.c
+@@ -559,16 +559,16 @@ redisplay_dirty(ScreenPtr screen, PixmapDirtyUpdatePtr dirty)
+ {
+ RegionRec pixregion;
+
+- PixmapRegionInit(&pixregion, dirty->slave_dst);
++ PixmapRegionInit(&pixregion, dirty->secondary_dst);
+
+- DamageRegionAppend(&dirty->slave_dst->drawable, &pixregion);
++ DamageRegionAppend(&dirty->secondary_dst->drawable, &pixregion);
+ #ifdef HAS_DIRTYTRACKING_ROTATION
+ PixmapSyncDirtyHelper(dirty);
+ #else
+ PixmapSyncDirtyHelper(dirty, &pixregion);
+ #endif
+
+- DamageRegionProcessPending(&dirty->slave_dst->drawable);
++ DamageRegionProcessPending(&dirty->secondary_dst->drawable);
+ RegionUninit(&pixregion);
+ }
+
+cgit v1.2.1
diff --git a/x11-drivers/xf86-video-nouveau/xf86-video-nouveau-1.0.17.ebuild b/x11-drivers/xf86-video-nouveau/xf86-video-nouveau-1.0.17.ebuild
index af511dafe0b2..c9a67c0af74d 100644
--- a/x11-drivers/xf86-video-nouveau/xf86-video-nouveau-1.0.17.ebuild
+++ b/x11-drivers/xf86-video-nouveau/xf86-video-nouveau-1.0.17.ebuild
@@ -22,3 +22,7 @@ RDEPEND=">=x11-libs/libdrm-2.4.60[video_cards_nouveau]
>=x11-libs/libpciaccess-0.10
virtual/libudev:="
DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-xorg-server-API-rename.patch
+)