summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-dummy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /x11-drivers/xf86-video-dummy
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'x11-drivers/xf86-video-dummy')
-rw-r--r--x11-drivers/xf86-video-dummy/Manifest2
-rw-r--r--x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild18
2 files changed, 11 insertions, 9 deletions
diff --git a/x11-drivers/xf86-video-dummy/Manifest b/x11-drivers/xf86-video-dummy/Manifest
index a47ca718d698..14d151e756e3 100644
--- a/x11-drivers/xf86-video-dummy/Manifest
+++ b/x11-drivers/xf86-video-dummy/Manifest
@@ -1,3 +1,3 @@
DIST xf86-video-dummy-0.3.8.tar.bz2 302353 BLAKE2B 1327db3aeec2ff7e3ff0876b25eace6fcdc7fc428967dee9f0b8ee4c22dd7904dcb47d5433bdc14ab56638225b2d33f3a26543dc9e6041c60af4135c1555f798 SHA512 f534113fd9987e44d2e0d0c53bd1b71be4ba69ec239ecec4aba8fcdcc10597722c54cbc01da38e0975ac7660e4e4028330e4cdd369e755c25ec059d2dfabad80
-EBUILD xf86-video-dummy-0.3.8.ebuild 460 BLAKE2B fe78fda2df3a00bb2d4bca5bdf398d8678fef03b47888c8139c6a4214b905d53bd6ab93937c5f65d3eeef84eeef33b387cd02bf3e05f6568d9717ea13c6d54bb SHA512 5d90ef45ed0b5a5bf2ad1b9e716870a054708211625aeb92792eaae3edcbc154e96d590468534cab5e68d812adfd1de2de86f975d304e84acdc1f634df93e48f
+EBUILD xf86-video-dummy-0.3.8.ebuild 468 BLAKE2B af26748a2154671dc1893b62721d2cc9ecf94c79120396ac9a2b941d2e8ac67bb7be607cd863a863e9c70636a2591efe3573053b132a9c267f299b32f44a1151 SHA512 f9373e6e6cdd2bb63c15446fa2d2ea69104627515a1a0da1769b3382f96ec227c179ae151793c1a165a501af419ee2193849ac74e99b415d62c28bfcbf5173ff
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild
index 436ff4aaa8a9..93c6b8a3bb46 100644
--- a/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild
+++ b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.8.ebuild
@@ -1,21 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit xorg-2
+EAPI=7
+
+inherit xorg-3
DESCRIPTION="X.Org driver for dummy cards"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="dga"
-RDEPEND=">=x11-base/xorg-server-1.0.99"
-DEPEND="${RDEPEND}
+RDEPEND="x11-base/xorg-server"
+DEPEND="
+ ${RDEPEND}
dga? ( x11-base/xorg-proto )"
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable dga)
)
- xorg-2_pkg_setup
+ xorg-3_src_configure
}