summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-wacom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-29 03:22:09 +0100
commitd4bd6695641f6d2ec7ff8681913d304e995902f5 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /x11-drivers/xf86-input-wacom
parent22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (diff)
gentoo resync : 29.05.2018
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest1
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0-r1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index 3056d61641d2..7aee5fb0db75 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -4,5 +4,6 @@ DIST xf86-input-wacom-0.35.0.tar.bz2 601314 BLAKE2B 59c2b03b79d141b71583ce3ea6ac
DIST xf86-input-wacom-0.36.0.tar.bz2 611678 BLAKE2B b3fc8310514e6e07c3c25fceeb982d66e9e10730028af769cd331578a48720666a0872b625beb15c7f68bbb291293dfe4c4e305411310c67bb2bd148e7d570d8 SHA512 48e4cf945eb0f5c7c65d46153756372bbfd6d1f101cd90f609c71cc21b36fa671d98c7be0b52d519775c7e7b875ec441d4308cf70d7897198600553e7a93ccc5
EBUILD xf86-input-wacom-0.34.0.ebuild 1852 BLAKE2B 3556b5b14f5775211639e77d9dedd7aea4243b98e82fe1913a2e50346132a18f562ccf5909d99501ed2933c5a1cb42005ed6b5e94b3123ba9340da9c4213c92a SHA512 e190da2d8eedb07fd74b6cbde5e56709be235aff114c0ca2f90de00221ad72dd2785d2b1eab3e321b688735fbf160c47d3719f5f5d690bd52c580f845363e0d7
EBUILD xf86-input-wacom-0.35.0.ebuild 1796 BLAKE2B 31162072ec86bc739f196393d7d97d5fd07e45cc7f9fba20b8be587c383e76a4683c66b93eeb717422c49ea94b4677248958510c61ff97fc5c725d5be8bb295a SHA512 e361c2f8e2c102e19f24e638ff4aca3eb2a831b5244b098d59ce12ef722058114875ec5351f3b18a19311e090cf2bef38a0bd559ea808a53a9ce56e2125f31cb
+EBUILD xf86-input-wacom-0.36.0-r1.ebuild 1740 BLAKE2B 1b0226a589dd3d0896b488e517738c176051b36a8fdaeedcb7f46607c80aa63c6e650c3e85be08255b60550d8d07e47014d436950237574fbedf14bd0137e3e9 SHA512 25e75b18cb4eeaa65c12bf90264a2894b97e7f33ef8c4a4ce27f17898143e86afb093d7c071c33618552c5bbe772973c41fea36210cb02893ce7e4edfc1747ff
EBUILD xf86-input-wacom-0.36.0.ebuild 1788 BLAKE2B aacfafed4bfb275c658862bb7c47ddd3068a7ed9076d9b0e5267547a8df5c4f70fd7b434dc723cd193eda835972334bddafd9664904dbdfe4b47f343a808843f SHA512 11856ffc1d0b8336002ce9802115f62586f4675383bc7616cded1152d131feea42c74460ec3419aeeafa37efb4f807cf9d70e90401c74af1f7f13ccce64f08c6
MISC metadata.xml 436 BLAKE2B 255853d810de0bc1d6fdefd359d613163d1277f2eb423e81fe29c3a699f4cee22731b52286d68c64aa3a1b579b3f723a5b86a8d45d18962d234f4f0cb316c7f5 SHA512 2aa103f44b3d36ff6466ac1fb010b25c649f1cc19d2db1d5c9b1ad54d954184eb7c55496feb58174bd466a9296f6c3eb269819b9036486a071a8100b1a3a6cb2
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0-r1.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0-r1.ebuild
new file mode 100644
index 000000000000..4bcff4b9fed2
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.36.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://git.code.sf.net/p/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/libwacom
+ virtual/libudev:=
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${ED}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 3 17; then
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ else
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ fi
+
+}