summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-wacom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /x11-drivers/xf86-input-wacom
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest2
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.40.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index 8d9333479ad7..b31601c792bd 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1,3 +1,5 @@
DIST xf86-input-wacom-0.39.0.tar.bz2 622440 BLAKE2B c0a76c36e03bc4153ac62fa61dc5a588588f5d4dfff0bc0710ef20cc4be9cb80e4fd972d1edc734a18155926c77c8a205e5a55e0e223dc2af96a193da1bdbcb3 SHA512 9ad92c86c4ba3587d68e2107057c89dfe8628c0a2ec882f5a424ab4983c18ff6048489d7f6d3a8de87403744f74de1982de25327fc955bb5c21346a242e0aaa3
+DIST xf86-input-wacom-0.40.0.tar.bz2 629310 BLAKE2B 63b930d3cd786d825250048fdf368fff4e607a39bfabee44e42a2c3ce9693c44ec8966871759d06b823f0568c4e3c2aee003633b863f5437eedc3125f19dd351 SHA512 ce0a24e2e9b4768e7eb65a5c663b3adce856356da7b83a1367dd7e031525805fc26d0b7c8b176a21fcd949c757940e18fec51d7253da157c0ac43ca446c4e536
EBUILD xf86-input-wacom-0.39.0.ebuild 1816 BLAKE2B 37290b4635b2f798dc1d1b91e88c4b827dce4145f1f25db100b346460b19ec073678632af7b930d5ad5e30f632ed920ad3822990714e3328265faa88a84f890f SHA512 93671cd2d4654e489e008fbbda6a3b9edf36074b709305b33a9c7d036e95a54579d842fd0ba148f69f57041aa7902776688d42fc0285c4b1d85d105c8d631320
+EBUILD xf86-input-wacom-0.40.0.ebuild 1822 BLAKE2B 59a5f99a6e7669933e123f61612afd6d80becc7988bb00cc3a641f87b026de8834647fb3cac89e3e1d8997819a3d0c751e0cfed3a2948ab9fde24e4a239199a0 SHA512 85695d6504a23a1ace5e1a8cb6d7b5cf8bdf5a09ea45b8b78993c5de1224316f36e632d9e4760f9f5c7a48742b693bb46a1f0b87a4d6a29c97ceeb3de62ba811
MISC metadata.xml 336 BLAKE2B 695ad5dc8eb6e6aa5d1dd2d6c462e077ca1aede7a309de0a9b13744299e4894514f6f83d42e39457751fd42dd7408a496d6ba6533387ebc130cab3ee21ce7405 SHA512 780490741b739aff3ba3d1a4fe1861c3b198196dd3a1ce471d5637d2c2b2a19b2aadda8103defd41a010b70bb5dad1fc00a78552c1b0ea8fab280423259fb360
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.40.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.40.0.ebuild
new file mode 100644
index 000000000000..9f3d6c1d1a7c
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.40.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd udev xorg-3
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="https://linuxwacom.github.io/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="https://github.com/linuxwacom/xf86-input-wacom"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/libwacom
+ virtual/libudev:=
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ --with-udev-rules-dir="$(get_udevdir)/rules.d"
+ $(use_enable debug)
+ )
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 3 17; then
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ else
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ fi
+}