summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-wacom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-04 04:07:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-04 04:07:19 +0100
commit2475ac51234b6ca2597db80dd05deb29667888b0 (patch)
treec3b38e5475d765253892cebd14aa2eb4822ef00f /x11-drivers/xf86-input-wacom
parent2764a2c09ef0bc530bda7afb20e505ca24d310c6 (diff)
gentoo auto-resync : 04:07:2023 - 04:07:19
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest2
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-1.1.0.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index c79c02f188ae..273eeca237fa 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1,3 +1,5 @@
+DIST xf86-input-wacom-1.1.0.tar.bz2 645948 BLAKE2B fccc81f49777b10527072bf4b30cb1a510e35d61f30fca96a68d05df55acc91f6c8dc44b2fad5d2b2f3f000646d85b2052841cbc8f933db51b668b1eb3e49dbe SHA512 d4ca8d5ea5e328c6e6b4bdb3d0ca23dee0bdb960e79f4422483d456330f9c88ea7579da4fba192fd250b23d7db1b7f40ad8ef0127f334c580030858edcbb9f4d
DIST xf86-input-wacom-1.2.0.tar.bz2 647874 BLAKE2B c59e605bacb2694c2e322faba9b030112ffb57f916c816cbcb9a946fa063713c0590e1ea29273f73a84f4360b5bc5241c9768d7e61d77dfc9fb0af72b1a6f1cc SHA512 34817b87318d1fcf885e6427436a54d748a1c910026e6af0a22fafb461b227ca566cf06846f1f57c0d66412d5a3b20c95f014a71f8ef394ea8ca360a5f902318
+EBUILD xf86-input-wacom-1.1.0.ebuild 1918 BLAKE2B 9e0f2b9438782ff2894d576db4ed7e63b566961436ab49c471ee5658bbc852453b6f3faaa790766e645633438be13776887eac325686fdc3c5e6fea0d3489b3e SHA512 2a991e5afb0860baa6fafaa875cf192fdb936563ba6501cd131c8b20a59dd241ff18355634b8e752668c2c6866cecc433e5e1ebb0a1ca96b49af00ea57d16314
EBUILD xf86-input-wacom-1.2.0.ebuild 1918 BLAKE2B 508aa3ec637806433278223879451b8b6eec906d4f1826ee6933961ea0bbf0438155bd8aad7b867bb941b3a5d4461ea2237beafb48b96a53fff67f43c06fbb1a SHA512 9be4d52b4478e20d165e6196a759218c8623bf9b64ca8b7e6ed38003f383a46893fc7879d79efbf80e4df9c08fc6f05c3b5ab2e0654fc2ac955d4b24b23d62d2
MISC metadata.xml 337 BLAKE2B 4af5fa6cfa58ef6ecec60cbe9f316cc4adfa0b1eb304d2c1fe4525b916e1c347bd3b9a74c2e79a5bb88649aae92f00b624c619169fc8cb6ac81e359e58c53d2b SHA512 fba2d6d8bbfe90c65794dd1b831c6bad7dcd2b6e67036f46d629f4e85f926409b7fba0e99892ce7a2ce527fd080d5e75467d0ec38fee0ea2f7ecd311c2c49893
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.1.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.1.0.ebuild
new file mode 100644
index 000000000000..1a8b5710751b
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.1.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd udev xorg-3 meson
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="https://linuxwacom.github.io/"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ppc ppc64 sparc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libwacom-2:=
+ >=x11-base/xorg-server-1.13:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama
+ virtual/libudev:="
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 3 17; then
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ else
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ xorg-3_flags_setup
+
+ local emesonargs=(
+ -Dsystemd-unit-dir="$(systemd_get_systemunitdir)"
+ -Dudev-rules-dir="$(get_udevdir)/rules.d"
+ $(meson_feature test unittests)
+ -Dwacom-gobject=disabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}