summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-wacom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /x11-drivers/xf86-input-wacom
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest2
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-1.0.0.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index 4ce0e953631f..281eb39c1928 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1,3 +1,5 @@
DIST xf86-input-wacom-0.40.0.tar.bz2 629310 BLAKE2B 63b930d3cd786d825250048fdf368fff4e607a39bfabee44e42a2c3ce9693c44ec8966871759d06b823f0568c4e3c2aee003633b863f5437eedc3125f19dd351 SHA512 ce0a24e2e9b4768e7eb65a5c663b3adce856356da7b83a1367dd7e031525805fc26d0b7c8b176a21fcd949c757940e18fec51d7253da157c0ac43ca446c4e536
+DIST xf86-input-wacom-1.0.0.tar.bz2 629019 BLAKE2B 4270dd4988a40d1307d15fce7fa0b6748db754e779cff5473b7a8f8ca5d0bbb36fd6125186e3ddba073f5521ee5c8657523d57dfaa82937a9d50b06605bcb8d1 SHA512 61b48380d8874241bbf687a3916aa089af087e50be93034cfc701a3311513ff855705e3e4073590a1b55be9751ab744166ddf14aa2311fdf0ccc01122af8e315
EBUILD xf86-input-wacom-0.40.0.ebuild 1882 BLAKE2B bddb296eb4ea85cbb251e88f3bac83fd14eed98b94d6c57a7ce489e985b418308edc38f53dbf5fc3348efc22696fd0597439d1655b93985afb0abbf80fbf5007 SHA512 91d9d201e7446a55a5302cc3aec95aa19307f5e3edca8350a960416b24fa31d87267e91634e8ac52063369051dea39410513aa9da0863b628b3344682b798fed
+EBUILD xf86-input-wacom-1.0.0.ebuild 1893 BLAKE2B 2f3a80da39b37284d8a981ac0a1b5c5c71fd6a793fa0e6318fe7fc5dc96225a266a4fae9f92bc965d292b0ba612a18c95cb9fbe1c6f42050274001eb1a1732dc SHA512 32d63083f61f2bceadb666c20afc4f2947d2e926c7ffcc22bd1473ad23466cfa5072c432d00a189c5b2eed80c690e328c0f8ffa3ec53900b5ae48601142534bc
MISC metadata.xml 337 BLAKE2B 4af5fa6cfa58ef6ecec60cbe9f316cc4adfa0b1eb304d2c1fe4525b916e1c347bd3b9a74c2e79a5bb88649aae92f00b624c619169fc8cb6ac81e359e58c53d2b SHA512 fba2d6d8bbfe90c65794dd1b831c6bad7dcd2b6e67036f46d629f4e85f926409b7fba0e99892ce7a2ce527fd080d5e75467d0ec38fee0ea2f7ecd311c2c49893
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.0.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.0.0.ebuild
new file mode 100644
index 000000000000..3805f49a4e28
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd udev xorg-3 meson
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="https://linuxwacom.github.io/"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libwacom-2:=
+ >=x11-base/xorg-server-1.13:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama
+ virtual/libudev:="
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 3 17; then
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ else
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ xorg-3_flags_setup
+
+ local emesonargs=(
+ -Dsystemd-unit-dir="$(systemd_get_systemunitdir)"
+ -Dudev-rules-dir="$(get_udevdir)/rules.d"
+ $(meson_feature test unittests)
+ -Dwacom-gobject=disabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ udev_reload
+}