summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-synaptics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
commit7b9f15840068dfaeea5684f8a1af1fe460dfa14c (patch)
tree112eea4497761c0227537330b58f9c7e0af3f9d8 /x11-drivers/xf86-input-synaptics
parent0bff53119f08d677db6c1a991bd30741682a8a08 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'x11-drivers/xf86-input-synaptics')
-rw-r--r--x11-drivers/xf86-input-synaptics/Manifest2
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-synaptics/Manifest b/x11-drivers/xf86-input-synaptics/Manifest
index 31a06cb319dd..747313c25447 100644
--- a/x11-drivers/xf86-input-synaptics/Manifest
+++ b/x11-drivers/xf86-input-synaptics/Manifest
@@ -1,3 +1,5 @@
DIST xf86-input-synaptics-1.9.0.tar.bz2 501814 BLAKE2B 7720136dba4e3cb76d21a9624e7e684bc09e22ebd0bc3b53fb170bbfebc29133dcfb471df326ac7b2eec1e4d3e2a3eeef56e57f649ddcc8f4d5e66eba9bd28e8 SHA512 71171ce59136b1c85764d412f9039d6252c94bb2ba44c8c6348aef6509d12219ea17a026440b0e18d26f4d7853d4ca5713eb2404d39deebb8be82886ad57bad4
+DIST xf86-input-synaptics-1.9.1.tar.bz2 503722 BLAKE2B 5ff2f792d187ff0f3fabb1ee194f4eae1397d993627ef3a74b1c838cd611fc2834c6453b57d0dc27d7a6e0bc69b717eb1cb76c87833dd1c66b1af5ac824e1d55 SHA512 978eddd456aa7361047bc3d72e5127b24b13de29b0dddb6a0acc9f9da93931baa2b22fb5d1e6be164f629a11e5d97d753b835426435396b45b1af5eb8d546c3f
EBUILD xf86-input-synaptics-1.9.0.ebuild 895 BLAKE2B 08a1e1ade11ff6d0cfaf10210627fbec65d82980c27c6997d26749588beea21b20d29af017077b26d8c53123694b1e7d68710fca96d9fbbcc66fc1cca9866482 SHA512 859c4152cb4cee9707918aafd3ad9d0b3faad6bfbfcc5b64a32e637696c730988aaddbd5b6953885c4aa9c566346f3291bbb395ef8c15b9046c0af81ea002915
+EBUILD xf86-input-synaptics-1.9.1.ebuild 895 BLAKE2B 08a1e1ade11ff6d0cfaf10210627fbec65d82980c27c6997d26749588beea21b20d29af017077b26d8c53123694b1e7d68710fca96d9fbbcc66fc1cca9866482 SHA512 859c4152cb4cee9707918aafd3ad9d0b3faad6bfbfcc5b64a32e637696c730988aaddbd5b6953885c4aa9c566346f3291bbb395ef8c15b9046c0af81ea002915
MISC metadata.xml 567 BLAKE2B 9681ddc834f81beea16bac80ee70737882f3daa8bb0081df819fdb8ebd335d760a036bc4913d5f8fb38c8b014f397d13fc96edce46118f8424b972f1c5bb22ef SHA512 87c2ca0134811881a7e13385d1f435dca2af70c63e833e23647085327e790a2a6a66e0257cdf4f2a30a5c1c268efdcd3b00b2bf4be6d69a35cd25486d73170cc
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
new file mode 100644
index 000000000000..f9182bd3397a
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="https://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
+IUSE="kernel_linux"
+
+RDEPEND="kernel_linux? ( >=dev-libs/libevdev-0.4 )
+ >=x11-base/xorg-server-1.14
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ x11-base/xorg-proto"
+
+DOCS=( "README" )
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}