summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
commit6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (patch)
tree401ffbc2ade49ce18f6182969ec5fb697a57ce48 /x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
parentd4bd6695641f6d2ec7ff8681913d304e995902f5 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild')
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
new file mode 100644
index 000000000000..f9182bd3397a
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="https://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
+IUSE="kernel_linux"
+
+RDEPEND="kernel_linux? ( >=dev-libs/libevdev-0.4 )
+ >=x11-base/xorg-server-1.14
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ x11-base/xorg-proto"
+
+DOCS=( "README" )
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}