summaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-libinput
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:12:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:12:17 +0100
commit580d27c925587ae7c65ac3d2706b1c8ce42b0463 (patch)
treebe152335ae762fc8404bd696b02425db417ae5c9 /x11-drivers/xf86-input-libinput
parent47af801ff0ee4a4207b36e6917b1e496354940c0 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'x11-drivers/xf86-input-libinput')
-rw-r--r--x11-drivers/xf86-input-libinput/Manifest3
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild50
-rw-r--r--x11-drivers/xf86-input-libinput/xf86-input-libinput-9999.ebuild50
3 files changed, 103 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-libinput/Manifest b/x11-drivers/xf86-input-libinput/Manifest
index 5a40a4c9f199..6d1fc41a8d3a 100644
--- a/x11-drivers/xf86-input-libinput/Manifest
+++ b/x11-drivers/xf86-input-libinput/Manifest
@@ -1,3 +1,6 @@
DIST xf86-input-libinput-0.27.1.tar.bz2 373248 BLAKE2B 499c5c1b33f5159374775317777741db361620583f9d647ab5ee63193f5b82ecbbe5c124a447509c6b7de281cf6330f9747032d8bad8c2b1dbbcdd4517cf4f82 SHA512 01379f5d71bf39214c4dff428173512df57fd12e782f3fcde757be923aa0dbf4e010a0395a81bd8e4fb518edc7e05ca1ee64b1e313eb4df5d4990315580609a1
+DIST xf86-input-libinput-0.28.0.tar.bz2 374318 BLAKE2B b8629115fce658d9d432c05a983227aa1fa40da51e14c366bc0880b9d7c81c971abcb4c4b60ec37b756efad60be8eef061c0d3dcdd86f4fdb8b56e13f4ed9409 SHA512 4276b6aea87ddc83fa1f5e8d8949e34ad117186a6b5b599549231cb90424cd0fa69f3a4701ce529739c676665bb5c936eb447817c9420511d23bc048f6be92a4
EBUILD xf86-input-libinput-0.27.1.ebuild 424 BLAKE2B f2308bb6428e36ccee7681f3e37d978f6aaedef8f81d9f577afcc0d5f8d5ea11a301b7ff19d5208aa7c4d9c6b9e2ded8a5d097fc312fd909bfb118bcecc615ee SHA512 1aac87fc2723d9a1cf5cef59289a807f747b0e99561cdd0ada145ea24dfd4e486f86883f9bed77b05e428a847e924e9da7edf514d199dc70cb341e4cf950bbf5
+EBUILD xf86-input-libinput-0.28.0.ebuild 973 BLAKE2B 036f9d13c8ec07777367cdadbbaf768329c0986737626ce25cb7653cdf7aa1f69747ac41e33ec4d31548747f3abd265aed69f77656ba0c01ad362c3de4197026 SHA512 1c3f5438620f6fe1482b81dbdf042b22d46d4d0b56054ba7cfefe8bc9d2357e17fb95eaeb77fdfe83106ef220b6912c9af72ad69a81b049ad7e95f266ea7e498
+EBUILD xf86-input-libinput-9999.ebuild 973 BLAKE2B 036f9d13c8ec07777367cdadbbaf768329c0986737626ce25cb7653cdf7aa1f69747ac41e33ec4d31548747f3abd265aed69f77656ba0c01ad362c3de4197026 SHA512 1c3f5438620f6fe1482b81dbdf042b22d46d4d0b56054ba7cfefe8bc9d2357e17fb95eaeb77fdfe83106ef220b6912c9af72ad69a81b049ad7e95f266ea7e498
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild
new file mode 100644
index 000000000000..b3ca6c70ccb5
--- /dev/null
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-0.28.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="X.org input driver based on libinput"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/xf86-input-libinput.git"
+ inherit autotools git-r3
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=x11-base/xorg-server-1.10:=
+ >=dev-libs/libinput-1.5.0:0=
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+pkg_pretend() {
+ CONFIG_CHECK="~TIMERFD"
+ check_extra_config
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/x11-drivers/xf86-input-libinput/xf86-input-libinput-9999.ebuild b/x11-drivers/xf86-input-libinput/xf86-input-libinput-9999.ebuild
new file mode 100644
index 000000000000..b3ca6c70ccb5
--- /dev/null
+++ b/x11-drivers/xf86-input-libinput/xf86-input-libinput-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="X.org input driver based on libinput"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/driver/xf86-input-libinput.git"
+ inherit autotools git-r3
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/driver/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=x11-base/xorg-server-1.10:=
+ >=dev-libs/libinput-1.5.0:0=
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+pkg_pretend() {
+ CONFIG_CHECK="~TIMERFD"
+ check_extra_config
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}