summaryrefslogtreecommitdiff
path: root/x11-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /x11-base
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/Manifest.gzbin1046 -> 1047 bytes
-rw-r--r--x11-base/xorg-proto/Manifest4
-rw-r--r--x11-base/xorg-proto/xorg-proto-2021.3.ebuild48
-rw-r--r--x11-base/xorg-proto/xorg-proto-9999.ebuild27
4 files changed, 74 insertions, 5 deletions
diff --git a/x11-base/Manifest.gz b/x11-base/Manifest.gz
index df33a9624d2c..2a14267baf15 100644
--- a/x11-base/Manifest.gz
+++ b/x11-base/Manifest.gz
Binary files differ
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index cc6ed62f05e5..199c4335901d 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1,4 +1,6 @@
DIST xorgproto-2020.1.tar.gz 1081369 BLAKE2B 1bed8d65499926a830180ee1fce5e5e57a276a6412231508eabb6c5eea5ee20dcce4046fc82203d5be88d1f24fb7919289393551d339e5cf5cb80b1c14f22c42 SHA512 d0bc3aec517fd00fa5fd32a5715760c34810a19154e10fb1f92f2e2fe7f26136f7ba9b76b47fcd37c3c4796663154f4e5abf6a18dd634619b0f718f3e4737ae9
+DIST xorgproto-2021.3.tar.gz 1130599 BLAKE2B 21aa84621984cd2635871c059ecbfe2c6290c74a3569f15cdce6080dd7e4106726ae9338112c075c8f64332ecb555a4ccb666bd7bf7e9bb1156b4591e5f37908 SHA512 0c2610551cc180b619611e0ad344e1a01cb0e5e83b3c8643cd6dbe19d8acc3a22e7c1522855923159dd753e4458c9f2d65b709bb045b27e17b83aa8c264e3d5a
EBUILD xorg-proto-2020.1.ebuild 760 BLAKE2B d5ee62b7f0fdf038006af93d7308c98768ab4a04567fb3a4eddde9230705105ac424de678b8499b8c5694a459b18f5fbda007b93f98958f16537531ccee3388a SHA512 63d593adb4886476c7f2abd99b309557fac32f23639a3094ab16fbb530e487a55f908576c285f747c27c743ed1c69b8461e465e59ca86543639dc8cdaa5fc74d
-EBUILD xorg-proto-9999.ebuild 762 BLAKE2B 96107b11d3dad0edd79ab67b513a3c1a0624aeb15514312f691546acbd9d9e9f2a6f4fc9b18cf0cd52a0fe5c99712e7181def059941fb0480fad9a2759c561ee SHA512 929ae7dc0cf21a197556c3e383a3ffc6bd631ef17a01ba9be4c08e47d80e49e8c4345dd3226abb38e8cc5d99a7c0c59e5c8a6911b937974134ce7f139215c57f
+EBUILD xorg-proto-2021.3.ebuild 1102 BLAKE2B 1149ac256e9aafa4eec429bcacc7245fee6caf4a6ea6dbf78749f947b81c08720daede7f059b116252156df77ac15f624aa30ede7c702c7bc1550ca454f385f8 SHA512 a156a1e5d9cd148a6eab8128ebf13c1d1d3656fd523bf0704f0a58becd94d1d45147354bba2e27dffd469fb4bfc2f79f7c488104ba9e231915d22b7b699a8543
+EBUILD xorg-proto-9999.ebuild 1102 BLAKE2B 1149ac256e9aafa4eec429bcacc7245fee6caf4a6ea6dbf78749f947b81c08720daede7f059b116252156df77ac15f624aa30ede7c702c7bc1550ca454f385f8 SHA512 a156a1e5d9cd148a6eab8128ebf13c1d1d3656fd523bf0704f0a58becd94d1d45147354bba2e27dffd469fb4bfc2f79f7c488104ba9e231915d22b7b699a8543
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-base/xorg-proto/xorg-proto-2021.3.ebuild b/x11-base/xorg-proto/xorg-proto-2021.3.ebuild
new file mode 100644
index 000000000000..2c391aa1de4d
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2021.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson python-any-r1
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND=""
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
diff --git a/x11-base/xorg-proto/xorg-proto-9999.ebuild b/x11-base/xorg-proto/xorg-proto-9999.ebuild
index cb69f9bbf9b3..2c391aa1de4d 100644
--- a/x11-base/xorg-proto/xorg-proto-9999.ebuild
+++ b/x11-base/xorg-proto/xorg-proto-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
MY_PN="${PN/xorg-/xorg}"
MY_P="${MY_PN}-${PV}"
@@ -12,18 +13,36 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
-inherit ${GIT_ECLASS} meson
+inherit ${GIT_ECLASS} meson python-any-r1
DESCRIPTION="X.Org combined protocol headers"
HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
fi
LICENSE="MIT"
SLOT="0"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND=""
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}