summaryrefslogtreecommitdiff
path: root/x11-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /x11-base
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/Manifest.gzbin1044 -> 1047 bytes
-rw-r--r--x11-base/xcb-proto/Manifest2
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.14.ebuild42
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-base/Manifest.gz b/x11-base/Manifest.gz
index d9717fe905c5..c081478687e1 100644
--- a/x11-base/Manifest.gz
+++ b/x11-base/Manifest.gz
Binary files differ
diff --git a/x11-base/xcb-proto/Manifest b/x11-base/xcb-proto/Manifest
index 6b8bcb04b6f7..a3730eeb9327 100644
--- a/x11-base/xcb-proto/Manifest
+++ b/x11-base/xcb-proto/Manifest
@@ -1,3 +1,5 @@
DIST xcb-proto-1.13.tar.bz2 151981 BLAKE2B 04d90838f8a892103e6d7aa807f1b0b6794f1538c6c986ad3cba67cff3a963ff680e45c2137c5d6330736a3aa1a387d61fc247f23487de9dada2f4013590b4a1 SHA512 002aa2aa0ad503977e03419c6f136f1e3aa8c787916830ce6d6be8f81ca99edc1d8fc5f71ce8c592b490cc767bf6567695f0bafe55fe3f743076bcddbaac07f7
+DIST xcb-proto-1.14.tar.xz 143384 BLAKE2B 60212b0f0ce039a64a2e6cbbc78564eeffc57cff20987b37dc780d8d97ae888a7dbfbbaadc6e0e4bedfc5d1e360f16318e3825ad8406de668d9c7c66cf7f4b5d SHA512 de66d568163b6da2be9d6c59984f3afa3acd119a781378638045fd68018665ef5c9af98f024e9962ba3eb7c7a4d85c27ba70ffafceb2324ccc6940f34de16690
EBUILD xcb-proto-1.13.ebuild 1570 BLAKE2B 9815944c3f934a4f1a8730e2c0c42f729b3c26cfc9df4715b8fdb0919b2d7318874f1f783359fba913091834beadfbdba521304fa008f3a0e6b9772403b636c8 SHA512 fa52928d5a7a2565c7049fc232bf8890ea28e8fe3fbbe4786c600c35ad7b2968829fffd7ecafafce457e6ff7fc9c2d82eec3cd560a38655ace8b2819895db6a4
+EBUILD xcb-proto-1.14.ebuild 1126 BLAKE2B 8c5407081463451dae4ec0cfd08835047b61a1babcf9959d7b0b2ea062343cf043a2f4730d1a969b87de81e1b3890d49aa47858e6566b1d23d628562b386f213 SHA512 0364e26f2e25d62d257f6af590f753033f3d27c081fb16602b9ac6386628cfac48cdfb2e48b1166a0068c6a3fff19b8e3a45886c38a2e4e29f5ec7ae85dbae6b
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-base/xcb-proto/xcb-proto-1.14.ebuild b/x11-base/xcb-proto/xcb-proto-1.14.ebuild
new file mode 100644
index 000000000000..1d2fe92f1d17
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+XORG_MULTILIB=yes
+XORG_STATIC=no
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="dev-libs/libxml2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl emake -C xcbgen top_builddir="${BUILD_DIR}"
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl emake -C xcbgen top_builddir="${BUILD_DIR}"
+ python_foreach_impl python_optimize
+ fi
+}