summaryrefslogtreecommitdiff
path: root/x11-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /x11-base
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/Manifest.gzbin1046 -> 1046 bytes
-rw-r--r--x11-base/xorg-proto/Manifest2
-rw-r--r--x11-base/xorg-proto/xorg-proto-2019.2.ebuild68
-rw-r--r--x11-base/xorg-x11/Manifest2
-rw-r--r--x11-base/xorg-x11/xorg-x11-7.4-r3.ebuild5
5 files changed, 73 insertions, 4 deletions
diff --git a/x11-base/Manifest.gz b/x11-base/Manifest.gz
index e275f5f792ee..10ddcd16132b 100644
--- a/x11-base/Manifest.gz
+++ b/x11-base/Manifest.gz
Binary files differ
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index 88a036c29e76..76a202cebfe0 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1,4 +1,6 @@
DIST xorgproto-2019.1.tar.gz 1119813 BLAKE2B eed29e0e236cc448b2ff220a844c68f69b0d1d2d7cfb4e82219731bbedadfc9352cf894ce8ba3c2a9f7dd1689a46be0a9ed4b0d061c661b752b0e81ef1057f27 SHA512 7d3a5b24cf5c5ff78c63f61b7e4e2fe6f8b6ca64c345422a1943688af8dccd621cf22833035ee632d37ebb96bf4864d1c18a8015373d69e734299cccb481615a
+DIST xorgproto-2019.2.tar.gz 1080686 BLAKE2B 4e0218ef02a8df5220431ae36ac1bc8feaa2bfdefe784f9b7393fe1d27db5b39ba90a38a3570bd78279964c5842ea65df3724b2407535a43fd867922156d92e9 SHA512 3385e7eb8ae1384aa01945c7f5a300884a1deb8d564ab62bd5bcaa3703d3dbf9bbc19797ac17d19e15417bf8456f706f993e90ece2d34cc94046ac302c062cbe
EBUILD xorg-proto-2019.1.ebuild 1831 BLAKE2B f438bb723233bff299d9b1b66e6751a547213394d7e727676a13fad6a1627db58538a8a8b5802a253c815ce9a95e59c0b8c17337fa4592c217febbef24cb4e68 SHA512 222d4db07f7c8e09243f10e220920421dbb7e0d6b7532f718957209c2f937c762a659f7bc82b3ba6c853752c7c85ccc5529a06023e3360b367d68422f183fb95
+EBUILD xorg-proto-2019.2.ebuild 1842 BLAKE2B 636bd6612f6fce904998db0aa0ff56b2354b3300a990c26539e8a91fa79899e044783850c9b859561fcfe69280391d673a475dc3cf62df786f6b7312ab4e1e24 SHA512 6c07ceee7a91b2a43c4bcf525c2b5d0fd492bfb68f2691bdbb578a5a768f97a2e3871e92ba307c506190ca2e6f940f95f23fff1138d225108115587b298e5f07
EBUILD xorg-proto-9999.ebuild 1842 BLAKE2B 636bd6612f6fce904998db0aa0ff56b2354b3300a990c26539e8a91fa79899e044783850c9b859561fcfe69280391d673a475dc3cf62df786f6b7312ab4e1e24 SHA512 6c07ceee7a91b2a43c4bcf525c2b5d0fd492bfb68f2691bdbb578a5a768f97a2e3871e92ba307c506190ca2e6f940f95f23fff1138d225108115587b298e5f07
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-base/xorg-proto/xorg-proto-2019.2.ebuild b/x11-base/xorg-proto/xorg-proto-2019.2.ebuild
new file mode 100644
index 000000000000..0d8a1c69b15d
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2019.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ !<x11-proto/bigreqsproto-1.1.2-r1
+ !<x11-proto/compositeproto-0.4.2-r2
+ !<x11-proto/damageproto-1.2.1-r2
+ !<x11-proto/dmxproto-2.3.1-r2
+ !<x11-proto/dri2proto-2.8-r2
+ !<x11-proto/dri3proto-1.0-r1
+ !<x11-proto/fixesproto-5.0-r2
+ !<x11-proto/fontsproto-2.1.3-r1
+ !<x11-proto/glproto-1.4.17-r2
+ !<x11-proto/inputproto-2.3.2-r1
+ !<x11-proto/kbproto-1.0.7-r1
+ !<x11-proto/presentproto-1.1-r1
+ !<x11-proto/randrproto-1.5.0-r1
+ !<x11-proto/recordproto-1.14.2-r2
+ !<x11-proto/renderproto-0.11.1-r2
+ !<x11-proto/resourceproto-1.2.0-r1
+ !<x11-proto/scrnsaverproto-1.2.2-r2
+ !<x11-proto/trapproto-3.4.3-r1
+ !<x11-proto/videoproto-2.3.3-r1
+ !<x11-proto/xcmiscproto-1.2.2-r1
+ !<x11-proto/xextproto-7.3.0-r1
+ !<x11-proto/xf86bigfontproto-1.2.0-r2
+ !<x11-proto/xf86dgaproto-2.1-r3
+ !<x11-proto/xf86driproto-2.1.1-r2
+ !<x11-proto/xf86miscproto-0.9.3-r1
+ !<x11-proto/xf86vidmodeproto-2.3.1-r2
+ !<x11-proto/xineramaproto-1.2.1-r2
+ !<x11-proto/xproto-7.0.31-r1
+
+ !x11-proto/fontcacheproto
+ !x11-proto/xf86rushproto"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
diff --git a/x11-base/xorg-x11/Manifest b/x11-base/xorg-x11/Manifest
index 9fbe56110ee9..82b9227a306e 100644
--- a/x11-base/xorg-x11/Manifest
+++ b/x11-base/xorg-x11/Manifest
@@ -1,2 +1,2 @@
-EBUILD xorg-x11-7.4-r3.ebuild 3332 BLAKE2B 397da92978d954d9fe5e175748e925f2941019d73784fe16be9af791b506c418b2b4b9d2ba71aed0628a73c589aa0f4520aa87010fcd869af047cfd87ea9d270 SHA512 7b0ea0c49f583316f6ac8a511fc6c57afa913d5a12fdfb7e2ca5b7897ffd02eadfc56759c35f6ad2a0f1f66df00f10ce501d81d6f21da64ebb9fbb7dec177f70
+EBUILD xorg-x11-7.4-r3.ebuild 3317 BLAKE2B 741edf393b2b23f182fdd749639814f849fcb3c2507a1c316ac8698093a848ca3cc0ef69de4215d98562429bbf9616883aa6ca1b44c8881c942d7fd8616ced55 SHA512 00950b04a2c10f304f15cc13ac01020b07b3ac7210a0a1150f4f57c0d62ef187c3503413bab9736d16f04a635fa6d7388d05779d0f80ba9d4929a26fb1e21dd0
MISC metadata.xml 369 BLAKE2B 36a4c5573e4280020ac40830cae3056197c2eda56c3161265c163a82d18337da4a2efbfaf7dbd08c76f6231c40a19669e1785b84ce6c89ab5bbc2fbb9b2a1970 SHA512 d0aadbeb8260987c487e28e74ec895b5012c23b8422a12d629444ee54afbe8c266ccba1286e5b1b21366a97b4255ae8724148dcf58eefc3e966fdb382e11d467
diff --git a/x11-base/xorg-x11/xorg-x11-7.4-r3.ebuild b/x11-base/xorg-x11/xorg-x11-7.4-r3.ebuild
index eeaff05196d7..0e11f2cf8f4e 100644
--- a/x11-base/xorg-x11/xorg-x11-7.4-r3.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-7.4-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,8 +21,7 @@ RDEPEND="${RDEPEND}
x11-apps/bitmap
x11-apps/iceauth
x11-apps/luit
- x11-apps/mkfontdir
- x11-apps/mkfontscale
+ >=x11-apps/mkfontscale-1.2.0
x11-apps/sessreg
x11-apps/setxkbmap
x11-apps/smproxy