summaryrefslogtreecommitdiff
path: root/x11-base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-07 00:11:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-07 00:11:16 +0000
commit1b2360e7bab42e4045232887cb4f6c4a24ca3975 (patch)
tree6a5a60c4c59058ef39895ea69fb8e98eaa49aed8 /x11-base
parent22eaa60297c2dbc92dd1658fb7d8e46878552755 (diff)
gentoo auto-resync : 07:02:2025 - 00:11:15
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/Manifest.gzbin1551 -> 1550 bytes
-rw-r--r--x11-base/xwayland/Manifest2
-rw-r--r--x11-base/xwayland/xwayland-24.1.5.ebuild133
3 files changed, 135 insertions, 0 deletions
diff --git a/x11-base/Manifest.gz b/x11-base/Manifest.gz
index a9917c457abe..c39f923421ab 100644
--- a/x11-base/Manifest.gz
+++ b/x11-base/Manifest.gz
Binary files differ
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index 9e45d32362d0..0f64ba2ed975 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1,4 +1,6 @@
DIST xwayland-24.1.4.tar.xz 1302372 BLAKE2B 9ca30a423aa5395dda06e3d532a57dc241b4d56bdb0309a47e1075a146f1a7879dde20c46b9c645fc430f534ffe484d0e9448fc9eb74d519f146629176804dc5 SHA512 7d3e4fdf67f07f79d8ddefc0077d10f811fe5ab1f919a922b5afc5dd9843eb2e0bc0a8b225555a0886521eb04a993e06a250469d3594d5add34d6412c76c60f8
+DIST xwayland-24.1.5.tar.xz 1302484 BLAKE2B b7070725756ccfd8160f1231b8ae67c7aceab0a372d6fbdd1a9af81e97f3a8ad3f2e1aae30aebc7fdde74dec4ef86d790c9d7d786fb596bea8e2ae81d613e877 SHA512 4c821e62013c2c79edff364c3c5e34c58f9b0e0c411baba23d9ebe3fe1daf8bbb99e56b6041c5cba66a219d9f80c469a5ee1238cef728eda197f19e7bba1e74a
EBUILD xwayland-24.1.4.ebuild 2700 BLAKE2B 682f74258c8b727f553d4c9de1975e478abf1b04d90e8a7de895cdc4637d6e42024d1feb0294ae19732c29cafa2802da10bdbf8726e07d1e54afc108019b7e49 SHA512 6d33a6bd4a60437f9684a96fb83476db82c2c05e9eabb99e801c00c1c7079a9a0864716dc3108497fca6fbdcf6cf7dc8cff3107194228dfdd8df0ba4357ee42c
+EBUILD xwayland-24.1.5.ebuild 2706 BLAKE2B e7c0b2ec37475cc8ef14fca8c400d0bfcbad8351422baad85fb4df3ca35ce22d0a6c12ed1fcf81cd7cfc201034631c9665703c24ebb1ba6e821be5af7e1370eb SHA512 3a35f95b723ef6565984782f788549d910778bc1f5d798a67092a61b9efcacc2140b4e90b1e34003b793ca5ad43c43bf3f83a0d0f13897c98fa7698ff18e7dd5
EBUILD xwayland-9999.ebuild 2684 BLAKE2B f60153f9a0659ee758f8b77bf2b8956625a0ff86d54bcdd93447ab8c321e2babb84f0f260627105977e43d90ce75a7764580a357a77aea59bc810a4087b9b5b6 SHA512 81e17d04515359bd43209a8cf5b887a6de48c002aacb5a51cfb832ee37ec7af94935e486386854d99d018d5359ee658ad43aeb794d6cff893c8987363b9acf82
MISC metadata.xml 627 BLAKE2B 1d39badd8534a02eb9785acbfa9efa97823c134696d41397d1db294fa774da9b4f184e027dada1b718cff3d651c9b436a4812458abef1d70af4d7749963d822a SHA512 9d02c7a263144ecfa9aac594867efee3622823b264fc3305e11c4b396156f0c43b071804f6f0ae9850b67b09ae887d270a722b9c4c4482e5ea962eedb915ee79
diff --git a/x11-base/xwayland/xwayland-24.1.5.ebuild b/x11-base/xwayland/xwayland-24.1.5.ebuild
new file mode 100644
index 000000000000..a2c9b9687f42
--- /dev/null
+++ b/x11-base/xwayland/xwayland-24.1.5.ebuild
@@ -0,0 +1,133 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+ inherit git-r3
+else
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="libei selinux systemd test unwind xcsecurity"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/libbsd
+ dev-libs/openssl:=
+ >=dev-libs/wayland-1.21.0
+ >=dev-libs/wayland-protocols-1.34
+ media-fonts/font-util
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ media-libs/libglvnd[X]
+ >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
+ >=x11-libs/libdrm-2.4.116
+ >=x11-libs/libXau-1.0.4
+ x11-libs/libxcvt
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ x11-libs/libxkbfile
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+
+ libei? ( dev-libs/libei )
+ systemd? ( sys-apps/systemd )
+ unwind? ( sys-libs/libunwind )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ >=x11-base/xorg-proto-2024.1
+ >=x11-libs/xtrans-1.3.5
+ test? (
+ x11-misc/rendercheck
+ x11-libs/libX11
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-apps/xkbcomp
+
+ libei? ( >=sys-apps/xdg-desktop-portal-1.18.0 )
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ app-alternatives/lex
+ dev-util/wayland-scanner
+"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e "s/dependency('x11')/disabler()/" meson.build || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use selinux xselinux)
+ $(meson_use systemd systemd_notify)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ -Ddpms=true
+ -Ddri3=true
+ -Ddrm=true
+ -Ddtrace=false
+ -Dglamor=true
+ -Dglx=true
+ -Dipv6=true
+ -Dsecure-rpc=false
+ -Dscreensaver=true
+ -Dsha1=libcrypto
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+# -Dxvfb=true
+ -Dxv=true
+ -Dxwayland-path="${EPREFIX}"/usr/bin
+ -Dlibdecor=false
+ -Ddocs=false
+ -Ddevel-docs=false
+ -Ddocs-pdf=false
+ )
+
+ if [[ ${PV} == "9999" ]]; then
+ emesonargs+=(
+ -Dxorg=false
+ -Dxnest=false
+ -Dxvfb=false
+ -Dxwayland=true
+ )
+ fi
+
+ if use libei; then
+ emesonargs+=( -Dxwayland_ei=portal )
+ else
+ emesonargs+=( -Dxwayland_ei=false )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../bin/Xwayland /usr/libexec/Xwayland
+
+ meson_src_install
+
+ # Remove files installed by x11-base/xorg-xserver
+ rm \
+ "${ED}"/usr/share/man/man1/Xserver.1 \
+ "${ED}"/usr/$(get_libdir)/xorg/protocol.txt \
+ || die
+}