summaryrefslogtreecommitdiff
path: root/x11-base/xorg-server/xorg-server-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /x11-base/xorg-server/xorg-server-9999.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'x11-base/xorg-server/xorg-server-9999.ebuild')
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index 187e506211e4..fa2165bade9b 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
XORG_DOC=doc
inherit xorg-3 multilib flag-o-matic
-EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/xserver.git"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
DESCRIPTION="X.Org X servers"
SLOT="0/${PV}"
@@ -14,7 +14,7 @@ if [[ ${PV} != 9999* ]]; then
fi
IUSE_SERVERS="dmx kdrive wayland xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug +glamor ipv6 libressl minimal selinux +suid systemd +udev unwind xcsecurity"
+IUSE="${IUSE_SERVERS} debug elogind +glamor ipv6 libressl minimal selinux +suid systemd +udev unwind xcsecurity"
CDEPEND=">=app-eselect/eselect-opengl-1.3.0
!libressl? ( dev-libs/openssl:0= )
@@ -80,7 +80,13 @@ CDEPEND=">=app-eselect/eselect-opengl-1.3.0
systemd? (
sys-apps/dbus
sys-apps/systemd
- )"
+ )
+ elogind? (
+ sys-apps/dbus
+ sys-auth/elogind
+ sys-auth/pambase[elogind]
+ )
+ "
DEPEND="${CDEPEND}
sys-devel/flex
@@ -106,6 +112,8 @@ PDEPEND="
REQUIRED_USE="!minimal? (
|| ( ${IUSE_SERVERS} )
)
+ elogind? ( udev )
+ ?? ( elogind systemd )
minimal? ( !glamor !wayland )
xephyr? ( kdrive )"
@@ -152,8 +160,8 @@ pkg_setup() {
$(use_enable udev config-udev)
$(use_with doc doxygen)
$(use_with doc xmlto)
+ $(usex !elogind $(use_enable systemd systemd-logind) '--enable-systemd-logind')
$(use_with systemd systemd-daemon)
- $(use_enable systemd systemd-logind)
$(usex suid $(use_enable systemd suid-wrapper) '--disable-suid-wrapper')
$(usex suid $(use_enable !systemd install-setuid) '--disable-install-setuid')
--enable-libdrm