summaryrefslogtreecommitdiff
path: root/x11-base/xorg-server/xorg-server-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /x11-base/xorg-server/xorg-server-9999.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'x11-base/xorg-server/xorg-server-9999.ebuild')
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild30
1 files changed, 17 insertions, 13 deletions
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index 2fb9a72911bc..05df79d40fe4 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -3,7 +3,6 @@
EAPI=7
-XORG_DOC=doc
XORG_TARBALL_SUFFIX="xz"
XORG_EAUTORECONF="no"
inherit xorg-3 meson
@@ -21,6 +20,7 @@ RESTRICT="!test? ( test )"
CDEPEND="
media-libs/libglvnd[X]
+ dev-libs/libbsd
dev-libs/openssl:0=
>=x11-apps/iceauth-1.0.2
>=x11-apps/rgb-1.0.3
@@ -55,7 +55,6 @@ CDEPEND="
)
udev? ( virtual/libudev:= )
unwind? ( sys-libs/libunwind )
- >=x11-apps/xinit-1.3.3-r1
selinux? ( sys-libs/libselinux )
systemd? (
sys-apps/dbus
@@ -71,13 +70,12 @@ CDEPEND="
DEPEND="${CDEPEND}
>=x11-base/xorg-proto-2021.4.99.2
>=x11-libs/xtrans-1.3.5
- doc? (
- x11-base/xorg-sgml-doctools
- )
+ media-fonts/font-util
"
RDEPEND="${CDEPEND}
!systemd? ( gui-libs/display-manager-init )
selinux? ( sec-policy/selinux-xserver )
+ xorg? ( >=x11-apps/xinit-1.3.3-r1 )
"
BDEPEND="
sys-devel/flex
@@ -105,15 +103,12 @@ src_configure() {
# localstatedir is used for the log location; we need to override the default
# from ebuild.sh
# sysconfdir is used for the xorg.conf location; same applies
- # NOTE: fop is used for doc generating; and I have no idea if Gentoo
- # package it somewhere
local emesonargs=(
--localstatedir "${EPREFIX}/var"
--sysconfdir "${EPREFIX}/etc/X11"
--buildtype $(usex debug debug plain)
-Db_ndebug=$(usex debug false true)
- $(meson_use doc docs)
$(meson_use !minimal dri1)
$(meson_use !minimal dri2)
$(meson_use !minimal dri3)
@@ -127,18 +122,23 @@ src_configure() {
$(meson_use xnest)
$(meson_use xorg)
$(meson_use xvfb)
- -Ddefault_font_path="${EPREFIX}"/usr/share/fonts
+ -Ddocs=false
-Ddrm=true
-Ddtrace=false
-Dipv6=true
-Dhal=false
-Dlinux_acpi=false
-Dlinux_apm=false
+ -Dsecure-rpc=false
-Dsha1=libcrypto
-Dxkb_output_dir="${EPREFIX}/var/lib/xkb"
- -Dxwayland=false
)
+ if [[ ${PV} == 9999 ]] ; then
+ # Gone in 21.1.x, but not in master.
+ emesonargs+=( -Dxwayland=false )
+ fi
+
if use systemd || use elogind; then
emesonargs+=(
-Dsystemd_logind=true
@@ -147,7 +147,7 @@ src_configure() {
else
emesonargs+=(
-Dsystemd_logind=false
- $(meson_use suid suid_wrapper)
+ -Dsuid_wrapper=false
)
fi
@@ -157,8 +157,12 @@ src_configure() {
src_install() {
meson_src_install
- #The new meson build system do not leave X symlink
- ln -s Xorg "${ED}"/usr/bin/X
+ # The meson build system does not support install-setuid
+ if ! use systemd || ! use elogind; then
+ if use suid; then
+ chmod u+s "${ED}"/usr/bin/Xorg
+ fi
+ fi
if ! use xorg; then
rm -f "${ED}"/usr/share/man/man1/Xserver.1x \