summaryrefslogtreecommitdiff
path: root/x11-base/xorg-server/xorg-server-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /x11-base/xorg-server/xorg-server-9999.ebuild
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'x11-base/xorg-server/xorg-server-9999.ebuild')
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index e9c4e0045348..25dac9a8620a 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -4,6 +4,7 @@
EAPI=7
XORG_DOC=doc
+XORG_EAUTORECONF="yes"
inherit xorg-3 multilib flag-o-matic
EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
@@ -14,7 +15,7 @@ if [[ ${PV} != 9999* ]]; then
fi
IUSE_SERVERS="dmx kdrive wayland xephyr xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} debug elogind +glamor ipv6 libressl libglvnd minimal selinux +suid systemd +udev unwind xcsecurity"
+IUSE="${IUSE_SERVERS} debug elogind ipv6 libressl libglvnd minimal selinux +suid systemd +udev unwind xcsecurity"
CDEPEND="libglvnd? (
media-libs/libglvnd
@@ -51,11 +52,6 @@ CDEPEND="libglvnd? (
>=x11-libs/libXres-1.0.3
>=x11-libs/libXtst-1.0.99.2
)
- glamor? (
- media-libs/libepoxy[X,egl(+)]
- >=media-libs/mesa-18[egl,gbm]
- !x11-libs/glamor
- )
kdrive? (
>=x11-libs/libXext-1.0.5
x11-libs/libXv
@@ -71,7 +67,8 @@ CDEPEND="libglvnd? (
!minimal? (
>=x11-libs/libX11-1.1.5
>=x11-libs/libXext-1.0.5
- >=media-libs/mesa-18[X(+)]
+ >=media-libs/mesa-18[X(+),egl,gbm]
+ media-libs/libepoxy[X,egl(+)]
)
udev? ( virtual/libudev:= )
unwind? ( sys-libs/libunwind )
@@ -118,7 +115,7 @@ REQUIRED_USE="!minimal? (
)
elogind? ( udev )
?? ( elogind systemd )
- minimal? ( !glamor !wayland )
+ minimal? ( !wayland )
xephyr? ( kdrive )"
UPSTREAMED_PATCHES=(
@@ -132,9 +129,10 @@ PATCHES=(
)
pkg_setup() {
- if use wayland && ! use glamor; then
+ if use wayland && use minimal; then
ewarn "glamor is necessary for acceleration under Xwayland."
ewarn "Performance may be unacceptable without it."
+ ewarn "Build with USE=-minimal to enable glamor."
fi
# localstatedir is used for the log location; we need to override the default
@@ -146,7 +144,6 @@ pkg_setup() {
$(use_enable ipv6)
$(use_enable debug)
$(use_enable dmx)
- $(use_enable glamor)
$(use_enable kdrive)
$(use_enable unwind libunwind)
$(use_enable wayland xwayland)
@@ -155,6 +152,7 @@ pkg_setup() {
$(use_enable !minimal dri)
$(use_enable !minimal dri2)
$(use_enable !minimal dri3)
+ $(use_enable !minimal glamor)
$(use_enable !minimal glx)
$(use_enable xcsecurity)
$(use_enable xephyr)