summaryrefslogtreecommitdiff
path: root/x11-base/xorg-server/xorg-server-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /x11-base/xorg-server/xorg-server-9999.ebuild
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'x11-base/xorg-server/xorg-server-9999.ebuild')
-rw-r--r--x11-base/xorg-server/xorg-server-9999.ebuild33
1 files changed, 12 insertions, 21 deletions
diff --git a/x11-base/xorg-server/xorg-server-9999.ebuild b/x11-base/xorg-server/xorg-server-9999.ebuild
index d1cbe013ded9..187e506211e4 100644
--- a/x11-base/xorg-server/xorg-server-9999.ebuild
+++ b/x11-base/xorg-server/xorg-server-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
XORG_DOC=doc
-inherit xorg-2 multilib versionator flag-o-matic
+inherit xorg-3 multilib flag-o-matic
EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/xserver.git"
DESCRIPTION="X.Org X servers"
@@ -101,7 +101,7 @@ RDEPEND="${CDEPEND}
"
PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
+ xorg? ( >=x11-base/xorg-drivers-$(ver_cut 1-2) )"
REQUIRED_USE="!minimal? (
|| ( ${IUSE_SERVERS} )
@@ -109,9 +109,8 @@ REQUIRED_USE="!minimal? (
minimal? ( !glamor !wayland )
xephyr? ( kdrive )"
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
+UPSTREAMED_PATCHES=(
+)
PATCHES=(
"${UPSTREAMED_PATCHES[@]}"
@@ -120,20 +119,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.18-support-multiple-Files-sections.patch
)
-pkg_pretend() {
- # older gcc is not supported
- [[ "${MERGE_TYPE}" != "binary" && $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 will not work for xorg-server."
-}
-
pkg_setup() {
if use wayland && ! use glamor; then
ewarn "glamor is necessary for acceleration under Xwayland."
ewarn "Performance may be unacceptable without it."
fi
-}
-src_configure() {
# localstatedir is used for the log location; we need to override the default
# from ebuild.sh
# sysconfdir is used for the xorg.conf location; same applies
@@ -176,18 +167,16 @@ src_configure() {
--without-fop
--with-sha1=libcrypto
)
-
- xorg-2_src_configure
}
src_install() {
- xorg-2_src_install
+ xorg-3_src_install
server_based_install
if ! use minimal && use xorg; then
# Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
+ dodoc "${S}"/hw/xfree86/xorg.conf.example
fi
newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
@@ -202,8 +191,10 @@ src_install() {
}
pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
+ if ! use minimal; then
+ # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
+ eselect opengl set xorg-x11 --use-old
+ fi
}
pkg_postrm() {