summaryrefslogtreecommitdiff
path: root/x11-base/xcb-proto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 03:31:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 03:31:10 +0100
commit280d9db9f9470686aae5ce1fa4cfa57b26e9beb2 (patch)
tree604fa555cdb815d5774494412f041887debf5220 /x11-base/xcb-proto
parent2ef316f0ffbd90d833effd2d09d1232e5767e321 (diff)
gentoo auto-resync : 17:08:2023 - 03:31:10
Diffstat (limited to 'x11-base/xcb-proto')
-rw-r--r--x11-base/xcb-proto/Manifest2
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.16.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-base/xcb-proto/Manifest b/x11-base/xcb-proto/Manifest
index 7da06a50dd82..556dc19eacfb 100644
--- a/x11-base/xcb-proto/Manifest
+++ b/x11-base/xcb-proto/Manifest
@@ -1,3 +1,5 @@
DIST xcb-proto-1.15.2.tar.xz 148108 BLAKE2B 0d6cc87ea0d2de594ba11b11255779e90d3c7507f0002453b3d1b2ac73fb604e5ee52e516bbcf76bce2a89027f8c8de6289d21aa2bb23d7d3e2ee77211b54946 SHA512 9d0b2f0a4dbbf2d64e32ff4658d1663e13d7e5f1bffc1e8d45be7b9dd5bab46e29fc1c2f6e66a7a569e374ba6756faf3c39b0b5e5560df6d7f8b68beec97659d
+DIST xcb-proto-1.16.0.tar.xz 151612 BLAKE2B 1c59ae4c71e697bd4f0298f6e0ea5235fc47baa9cf584e079258f1da8be538d1b67dc45f1325d82495247d0f8020d0244ca334de3794b410a1feaceabd6b285e SHA512 54906f379a7aa2cbbfbbe54764c02dbf522ca8f6c54e07d4faae471aac3aee25d0359be38c808c8da887de228aed745582a78b2f56714b023bca8f3513b24972
EBUILD xcb-proto-1.15.2.ebuild 1147 BLAKE2B f25c190fc8912316485c35daad086455bafe5d6cb05b648bcb8ce470d066eae2f2360871fddaf8ce3d815cf4244b1c43c5304471a3c5d580b25ee343ce49db33 SHA512 b33536d021d6bc96647f30eb49ff6f3b5687ed3f5c74bfbf24dbe86705e50096dd7340b350f603b94e10132c125624e59b8f6d72aae9b090ab169c1ad4823c02
+EBUILD xcb-proto-1.16.0.ebuild 1156 BLAKE2B 387e0c9a93d9ed55d78620241c94c957340e1f46263354bca49cf3368e90fcb08ac765217fa8464856c8c5388be484c30d7a4db55e9bdf132b4bd18c44abfe8e SHA512 5f456932bc322678c7bc5d71539917dfa008d8cfa3e168a0d825810e98d469449c989b6eb06362299980b613f295fcaece68611de4adfed829401cbaf5f532d7
MISC metadata.xml 341 BLAKE2B 96e3b6613178261ab586ecc15cb98a7de1f752c081744d02ce3b9976a07e22056ff5c564b418839486d106964daa7327bb3d4d57b469593ac1b4968fbfc3bf67 SHA512 1374a7a6fb6254afa291f3ed7fbc0ff5aa1e478ad2b6df17dcf6969cfcce7681eeb2fb82caa6cbcab5109d2ffd128d3d18819013855a2a338bde5dd93992b6f1
diff --git a/x11-base/xcb-proto/xcb-proto-1.16.0.ebuild b/x11-base/xcb-proto/xcb-proto-1.16.0.ebuild
new file mode 100644
index 000000000000..9eb776764a72
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.16.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2
+"
+
+ECONF_SOURCE="${S}"
+
+src_configure() {
+ # Don't use Python to find sitedir here.
+ PYTHON=true default
+}
+
+src_compile() {
+ :
+}
+
+xcbgen_install() {
+ # Use eclass to find sitedir instead.
+ emake -C xcbgen install DESTDIR="${D}" pythondir="$(python_get_sitedir)"
+ python_optimize
+}
+
+src_install() {
+ # Restrict SUBDIRS to prevent xcbgen with empty sitedir.
+ emake install DESTDIR="${D}" SUBDIRS=src
+ python_foreach_impl xcbgen_install
+}