summaryrefslogtreecommitdiff
path: root/x11-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
commita88eb1d9b7042912d196e255eeb20e0c77f6cf47 (patch)
tree291cc788e33b3de8bf1b5e3f1fdddf315f2f5ee7 /x11-apps
parentc3d14fe9accdf0b091e42f26a66ed7626ba8c24b (diff)
gentoo auto-resync : 01:05:2023 - 17:20:35
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/Manifest.gzbin14025 -> 14027 bytes
-rw-r--r--x11-apps/xinput_calibrator/Manifest4
-rw-r--r--x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild26
3 files changed, 20 insertions, 10 deletions
diff --git a/x11-apps/Manifest.gz b/x11-apps/Manifest.gz
index 11a37cb98c99..60721f6ee970 100644
--- a/x11-apps/Manifest.gz
+++ b/x11-apps/Manifest.gz
Binary files differ
diff --git a/x11-apps/xinput_calibrator/Manifest b/x11-apps/xinput_calibrator/Manifest
index c23dcc1e5732..943ca90c93ab 100644
--- a/x11-apps/xinput_calibrator/Manifest
+++ b/x11-apps/xinput_calibrator/Manifest
@@ -1,3 +1,3 @@
-DIST xinput_calibrator-0.7.5.tar.gz 355313 BLAKE2B 72c6b2f1b2cf4d5baaba27827e870adb52c4a51004a9a3f51376c5e30560b26abe6e83a94ae2e308a01dca3204a1938d888d40cad793cce50c1d9acea9f507b3 SHA512 dc022f4de6d7b57912373a571ef0598c7b9d91cdbc3f63bb2b32c6149e43f67eaf820dc0289349d527314381d5195cf8891f6bcb9847110662dd75875f76b9de
-EBUILD xinput_calibrator-0.7.5-r2.ebuild 638 BLAKE2B fb71f6c2669d13d8d99bf53889d258da5a5df152ae6a44ea5db998ebe33331f3b7fdf9bd12986ad6d0499ca33761e74007e0da9e27219f81eaa68a31f244e316 SHA512 c80d656103dc1db39d04c04ebbfbcadde634a720c3f44db836f2cd592029521970e2c6864de96a292a3b5bba7922d2f436cf4bf6221861694a7e3788551e8d65
+DIST xinput_calibrator-0.7.5.gh.tar.gz 38126 BLAKE2B 700c124a560ade4636f0861b04d5ed355a7b647fe565fedf8841165c709844ee5928db1c8868c7cce13d12b17bdece4ccdcebd51a6be248142fe7249615cbf4a SHA512 71bd27d5bdde02bdf41793a72743127ee930235db40e642e2584549e224cd9d2b36ad22e1b6a764ed431ab9590bf76c57e0075bc7b81b325caffb439dc755930
+EBUILD xinput_calibrator-0.7.5-r2.ebuild 729 BLAKE2B 37ab27ab4275b76538f77f71e6f6e66441a338fb41362f929a49bbc28c2661da58af57d777582134182d418964a6dc3fa57f683cba0d6ed020202fd4e518d38c SHA512 f83976b58c95a8dc0e372bb116e7f39e7793b7276ac8b1354a949a7149bcc49b3f70a18414d3882d817f4775b7b8b25969c61723a0ae47118d24b14d3ef878c8
MISC metadata.xml 332 BLAKE2B 62e8b37431558d65d24de1bc3f1edb5374d2da9ab49bd5fda1afe15479823e1a40174f9e0c069b96406d92f9fa48c9b8dd3f12b7daced813d39a5f55a8cda27a SHA512 1e452e53d38363914aecbeae3cc4d9a0eca424790d646a09ff522947461f1f51a71daa1f8aa1da96d82843a7595bf7528f0a627b49740c03dca8ef8289c1c410
diff --git a/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
index 7a3d3101534e..f8ce7f6cbc45 100644
--- a/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
+++ b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5-r2.ebuild
@@ -1,24 +1,34 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic
+
+inherit autotools flag-o-matic
DESCRIPTION="A generic touchscreen calibration program for X.Org"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/xinput_calibrator"
-SRC_URI="https://github.com/downloads/tias/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/tias/xinput_calibrator/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE=""
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
- x11-libs/libXrandr"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+ x11-libs/libXrandr
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
src_configure() {
append-cxxflags -std=c++11 #566594