summaryrefslogtreecommitdiff
path: root/x11-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
commit69051588e2f955485fe5d45d45e616bc60a2de57 (patch)
treeef8699cca7ce3773b1de747b167ceeacdc60cb92 /x11-apps
parentd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (diff)
gentoo resync : 31.01.2021
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/Manifest.gzbin14504 -> 14501 bytes
-rw-r--r--x11-apps/xinit/Manifest1
-rw-r--r--x11-apps/xinit/xinit-1.4.1-r1.ebuild75
3 files changed, 76 insertions, 0 deletions
diff --git a/x11-apps/Manifest.gz b/x11-apps/Manifest.gz
index 20b8a793fc30..4accbad2efc1 100644
--- a/x11-apps/Manifest.gz
+++ b/x11-apps/Manifest.gz
Binary files differ
diff --git a/x11-apps/xinit/Manifest b/x11-apps/xinit/Manifest
index afd670e01867..33e07b7e9e28 100644
--- a/x11-apps/xinit/Manifest
+++ b/x11-apps/xinit/Manifest
@@ -8,5 +8,6 @@ AUX xinit-1.4.0-startx-current-vt.patch 740 BLAKE2B f5ac87b96f76bd4c845cde4844f9
AUX xinit-1.4.1-move-serverauthfile-into-tmp.patch 745 BLAKE2B 6a964926b4f5eda566be4ff5c0f015ca2d3a9f39f16ba5af0cf3816c56cf458e616645ace1b8be9873c604322ab56b118a7a9e531533f8617cb647a57cf0cf3e SHA512 0fb93f0cebfd4091d7e58139ef375fec931392159b3b060d699d118c89d4403fd5cee82cd35582aedf7dd752aee495724119f864b17988d0dd9a5dfe76c88ce0
AUX xserverrc.2 143 BLAKE2B b33fac4b5ba731c79167d21a07840c46abfbb33e8fbb80aa1c3f23a8717f836819da3a947b72bd99c7a14516534e9771033bcd1e26d167f2f7083be20eae3b2f SHA512 61afea54f66b9f397860e467cf87a41e1d9f97d7194930bccc254e44dd4178bca7b402bff7aa2a1d6f44a91680f3f1ee10a5b57e527aaff80438623edc1b07c5
DIST xinit-1.4.1.tar.bz2 176206 BLAKE2B 1c20f34db344eb967ac230a0cd61ad07d0089668aea32973e9b8b9749e5260ad5d93a7f6642a4f2c8d6b01870696e4e1e422790c2954320039aa85e6dba8870a SHA512 6cbc5d025a891c419f3f4493381b2fca57a67d78df866d2f16a83426f86bad6eca7f240fac12b25cbcc63df0fec41f625407184e044898602d66483715315340
+EBUILD xinit-1.4.1-r1.ebuild 2223 BLAKE2B a08d930c38fb39644c1761dbdeab73346267bb0dbc2d4f8b13e9231011d7f0c681311a59a6fb9af6e5ac8897a853c1d50d46a1cb05813fde05b65a2f82232e52 SHA512 0dbc8b9558f9acdbd20d234ff3755867d1807dc4b532a94b27a9edd48fbfe0b0048a0d8a7396cb0c5ffa29fda326e9ef8ba6df8ca68c4ca28254abd36621d7f7
EBUILD xinit-1.4.1.ebuild 2247 BLAKE2B 255cdfec15b4a47ac2fae1651eaaa1fa41f3df5b21789e06ae4e99be9fb878affc279c37c80468566791432e268bcef75db72ecc67ef86eb33b43b929535da18 SHA512 e2730aa19d65b4c841fd2e0d57a55176bef218a9849ec6d11956b96166c527cbd0dcdba69ca50fffb856103ed60ed88ed57a8cf1e605cb8258b6b58b4b761c34
MISC metadata.xml 477 BLAKE2B 96cb48063d5da3ee74d3c6080b849841fb1b276338db584d51bac71b5b2c3df0ecd876055a3c11e18f46c4d879a90ef91713166cae2aef65ea7725ab639b116f SHA512 c3e1095f0e3e017439777b3113d16ceccdc5ee7127da7f9e994126d6f51227a07c831e082d58c9c094aa6fed3e789458a212e27ec497fd3a14ba4cc5e4956205
diff --git a/x11-apps/xinit/xinit-1.4.1-r1.ebuild b/x11-apps/xinit/xinit-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..36ce2267f5c7
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.4.1-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="twm"
+
+RDEPEND="
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ twm? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.3-gentoo-customizations.patch"
+ "${FILESDIR}/${PN}-1.4.0-startx-current-vt.patch"
+ "${FILESDIR}/${PN}-1.4.1-move-serverauthfile-into-tmp.patch"
+)
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir="${EPREFIX}"/etc/X11/xinit
+)
+
+src_install() {
+ xorg-3_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ newexe "${FILESDIR}"/xserverrc.2 xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/00-xhost
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/Xsession.desktop
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+ fi
+
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "$v" "-lt" "1.4.1"; then
+ ewarn "Starting with ${CATEGORY}/${PN}-1.4.1 serverauth files are no longer kept in the"
+ ewarn "home directory but rather are created in \$TMPDIR (typically /tmp). The change"
+ ewarn "is transparent for most of users, however those that use runtime temporary"
+ ewarn "directories cleaning tools, like app-admin/tmpreaper, may need to adjust them"
+ ewarn "not to remove the 'serverauth.*' files."
+ fi
+ done
+}