summaryrefslogtreecommitdiff
path: root/x11-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-28 05:11:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-28 05:11:40 +0100
commit2099ff9b640e648be67527e29760263a7c6274e5 (patch)
tree238358af0ba45fd8fcc6cd4679736d6c4f07f851 /x11-apps
parentd198e0ebeee70707545d19ee3beb1de70802cc7c (diff)
gentoo auto-resync : 28:04:2023 - 05:11:40
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/Manifest.gzbin14007 -> 14025 bytes
-rw-r--r--x11-apps/xdpyinfo/Manifest2
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.3.4.ebuild38
-rw-r--r--x11-apps/xrestop/Manifest2
-rw-r--r--x11-apps/xrestop/xrestop-0.6.ebuild26
5 files changed, 68 insertions, 0 deletions
diff --git a/x11-apps/Manifest.gz b/x11-apps/Manifest.gz
index e015258664b9..11a37cb98c99 100644
--- a/x11-apps/Manifest.gz
+++ b/x11-apps/Manifest.gz
Binary files differ
diff --git a/x11-apps/xdpyinfo/Manifest b/x11-apps/xdpyinfo/Manifest
index 9b5295850e2c..feefa92c1c48 100644
--- a/x11-apps/xdpyinfo/Manifest
+++ b/x11-apps/xdpyinfo/Manifest
@@ -1,3 +1,5 @@
DIST xdpyinfo-1.3.3.tar.xz 137088 BLAKE2B 8fdf49e65ac05ab27672ef2044044353f8bbfe0c8bf6135e71b9fbd45b3cb643f5794977802cbb7a44cfe9d20905b5e74b0cc41829c9fef837f32c81bb05ea2f SHA512 47fe0821bc64145876853712ebd7c0af80111c243813615b892429021cc9a53abd38c4684551ae300cb5a4eacdd3d26e2c93e789ed91a948b20e2c37cd2d2442
+DIST xdpyinfo-1.3.4.tar.xz 137064 BLAKE2B ea0e50d66c313e0f11164fe22cf9c46dcd9dafdcf0652895146a8f85e847e2f21ed2eb54f9512fd3a89657e44c6212b7c7de5359e304db660cfaa8c44a254356 SHA512 9ef9f5c10e15a40895e8f008896b960fdd438277657c7159d16f05db79cd2374cfaca4af2f4e59335824bfd2f74a045ef89dd99ea4130ed436ea59fbbb1cbe12
EBUILD xdpyinfo-1.3.3.ebuild 839 BLAKE2B 3f2f7ea5acfe02edc9afbd02adc844801fb5a03968e901d10a84d857e288af982c1bce8ec74355443a733cbd0e11917e342105da805212fbea70a3f56d1b9ece SHA512 85106268c09a3244b8e28574c99b9275a856dc066d25e3d4436efd5b5fab58937b732d964393772dd4775f11841d4cbd85749e4132c5568dd744190007012ed4
+EBUILD xdpyinfo-1.3.4.ebuild 846 BLAKE2B af3985391bd1e4cfe3ae536c644399890634ff87f247c2bfb0bbbee09efbb8412cc1f6776b9cb5e4988d4fe4d1314c03439c174ff3025211b8d9f0978d6d2f69 SHA512 4fb3886be6b5ef1fc352f5442f5cbdb06feec8d4f0628d07f4e930a64ae7f6dc60b3f9ab6476034ae798ca4dc882cb570a4008199dd3d47596152caf16b753bc
MISC metadata.xml 461 BLAKE2B da9d11bb2cbb59a1d75ce08d1a8b37bf35a74bde1382014fa38561874d10c66e3a0be8dd5251431183780a7d9c69b1cb256b1e31b6f6e4cd6767037105573de6 SHA512 a9706f84bd7b8d3a9b417e81cc984d285e66d43a9f9b8a4c3d7605e1d014fe3c62be9d33790b95e22d17e5bd6c88e3374f46fb6188ab9edeb34a4540a750adf5
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.3.4.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.3.4.ebuild
new file mode 100644
index 000000000000..10be5df80d78
--- /dev/null
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.3.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="Display information utility for X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
+IUSE="dga dmx xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ dga? ( x11-libs/libXxf86dga )
+ dmx? ( x11-libs/libdmx )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --without-xf86misc
+ $(use_with dga)
+ $(use_with dmx)
+ $(use_with xinerama)
+ )
+ xorg-3_src_configure
+}
diff --git a/x11-apps/xrestop/Manifest b/x11-apps/xrestop/Manifest
index 57909957cc8f..2a9afd85e38e 100644
--- a/x11-apps/xrestop/Manifest
+++ b/x11-apps/xrestop/Manifest
@@ -1,4 +1,6 @@
AUX xrestop-0.4-tinfo.patch 291 BLAKE2B b96d892c87a8133987baa94e5cb4917bc5d743c24ec11a2ec67afafc7206654b88c17f54377f2d1bf0c9fb92df8de16c99e4d0f9a15ff80a9417da2de31bc6fa SHA512 21993ada033d4ec744b55faa71afd736a99423f12071a64e1445958de979631ce42a908e14ef194e819de98766c92a2c2470b2c88d172879ec5fc4c20212566f
DIST xrestop-0.5.tar.bz2 135537 BLAKE2B cbb58870ff16148a34468231478c723fc41932c1e17156304a1885b52c17d870339c88bc4acde16d28cdd22cb227c2190b6b33bd472b047a82261924e681c889 SHA512 f50e1fcba2fdb6167f93b9edae721556bc411232a9d7cc1df853e588cd92608c9ca652bee1aaf5cfe3750d6c60db6c6cd1c6797e282841cc535051e78b2c4c1d
+DIST xrestop-0.6.tar.xz 125128 BLAKE2B 59424d3a1d2aa0b41b55c901686c032bcddbed167474e6a759705024bf017b6bfdad7ef9263609c14ab4db8ca087357cbc66f9c39f80a70b9740f4c2a2fe07b7 SHA512 bc46aa1f0664961a42a2ed1f204c3c3959429805936fcdd91a2bdbb7c46d8a19a213c9997f7d2365948220bdbc6d39ea654c5085baf6f7309540445877b62e3b
EBUILD xrestop-0.5.ebuild 599 BLAKE2B 56c3264696e0b91583263c3a24f5c078f4f419269aecdeaccd89230542ecd9d3e9f9f76caead6e5ad234a143c5295d5527409e3dffd1198abd7f56f3367ac911 SHA512 89076f6f277a800ce6faff99cb87717777374066425c0feb14bd34e5a58161bfad9fc23768d7ce01033a8e8af02887a6f15944276ff286dab004e36e1e4900eb
+EBUILD xrestop-0.6.ebuild 540 BLAKE2B 0e763a279e3d864f2a174957b56513dc3ce8ec295d168f7102c9a50c3b85d3def3df9f697c56d4d39242e5f078a7f98fc5db138d5d0b912c20ed90803510e06b SHA512 04a6566d8f1fb3730da156928ed874835666b28371b31e0ce4b53a0e7c25af24619283ca86256d71cf4012f32b050208904490323ae8285899216dddb9af5873
MISC metadata.xml 338 BLAKE2B 0ed6b9febb71b6ff1a5b8fd5ae50255db3cbfa0ea9ae95b1a8c30857d62f5a5a9fbcd80754075171c248eee5cccb9efb23881fba7ccbda6645c1e757c110b0a4 SHA512 2c677e4d4b4d14638499845dcc35a8673f4b4183f26d40b433e6806c16b89006f1c21c505c5fcdf1ea33bc290ff593c76e78170d943f588c170c9f2bbb0cf560
diff --git a/x11-apps/xrestop/xrestop-0.6.ebuild b/x11-apps/xrestop/xrestop-0.6.ebuild
new file mode 100644
index 000000000000..619b7b5fd6d9
--- /dev/null
+++ b/x11-apps/xrestop/xrestop-0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="'Top' like statistics of X11 client's server side resource usage"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xrestop"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="virtual/pkgconfig"