summaryrefslogtreecommitdiff
path: root/x11-apps/xwininfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-10 19:15:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-10 19:15:28 +0000
commitda6a52f691ef980bab92d003d5df8f463c623af8 (patch)
tree4d89e0d5915f8a3f57c8f9c17420ba3f7b44b7b2 /x11-apps/xwininfo
parent80208fb578cf92cc308906660ca6d7860c6b2a1f (diff)
gentoo resync : 10.03.2018
Diffstat (limited to 'x11-apps/xwininfo')
-rw-r--r--x11-apps/xwininfo/Manifest2
-rw-r--r--x11-apps/xwininfo/xwininfo-1.1.4.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/x11-apps/xwininfo/Manifest b/x11-apps/xwininfo/Manifest
index af17bd11dc3c..a2b56cf4d7e9 100644
--- a/x11-apps/xwininfo/Manifest
+++ b/x11-apps/xwininfo/Manifest
@@ -1,3 +1,5 @@
DIST xwininfo-1.1.3.tar.bz2 157512 BLAKE2B eba1f98cf8aa8afc68a5bc0f538e1e0588a38bd0022ba0a2bf6da7e2cbcd4459111aed37f88b8d46054f8c3e52e435d0c95a8f7c9b1247580dde812a3bd3715c SHA512 b4c3c72de157d33e309694be96dcafabb3240c1883fb3caf44843cba8b90fe09496eb4ab061eba9107115d76ca59a8ec660e11ff968e422ab35cd5e1749ca466
+DIST xwininfo-1.1.4.tar.bz2 169159 BLAKE2B 4bdf7321eba8e2cd078c3220e3135ca1b044461ab90b8daa350beed1feb53f02dd9dd4c1192be6dd6b9ef2a9dc028c4a9c464f3124590e6195aca7547ed61830 SHA512 d3ab103a0a311e08d1eabc4346750c21eb7d2fbcdc27cab0989a2624b9cd488911614fcf9832603353450114b1231a8f8262cab16e090a0d458d83ec7b6b959b
EBUILD xwininfo-1.1.3.ebuild 741 BLAKE2B 376b205354177dec9cd17d1d11f04413b18820608a7c38db078d3a10f888da97c85b4c67d3881185ed609583af26e680692bc2c464cc97c531dc16e9362dd57e SHA512 d48b8bba681614c0e5355c512977455cfde7de628cfaa3fd511dbe30b1eeb3b3e5c2bf950a6d384c2e8d9af9a49dbdf38b65f767a75d2e7692d0ccc666be6d84
+EBUILD xwininfo-1.1.4.ebuild 741 BLAKE2B 6f014028708c38e4f9390ed4678a6882ba9ee3e9fa00ad7cbf5f5d05b82a27002aa0ed52f69ad329e592451245e6ae4e5d76cac1024554eab2591c496b567fa3 SHA512 65041f52214a9171a378b30a87cd92a220d9a6d20776f5b1e3fa61948d67f938d4d1f173ae51769c3d7fe9cf4cfc80a996f2b8369791a4e3a6b4ee5bec302d3a
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-apps/xwininfo/xwininfo-1.1.4.ebuild b/x11-apps/xwininfo/xwininfo-1.1.4.ebuild
new file mode 100644
index 000000000000..4e7c0e6044cc
--- /dev/null
+++ b/x11-apps/xwininfo/xwininfo-1.1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit xorg-2 flag-o-matic
+
+DESCRIPTION="window information utility for X"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libxcb-1.6"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+ >=x11-proto/xproto-7.0.17"
+
+pkg_setup() {
+ # interix has a _very_ old iconv in libc, however, including
+ # iconv.h redefines those symbols to libiconv_*, which then
+ # are unresolved, as the configure check is old and dumb.
+ [[ ${CHOST} == *-interix* || ${CHOST} == *-solaris* ]] &&
+ append-libs -liconv
+}