summaryrefslogtreecommitdiff
path: root/x11-apps/xwininfo/xwininfo-1.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-apps/xwininfo/xwininfo-1.1.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-apps/xwininfo/xwininfo-1.1.3.ebuild')
-rw-r--r--x11-apps/xwininfo/xwininfo-1.1.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-apps/xwininfo/xwininfo-1.1.3.ebuild b/x11-apps/xwininfo/xwininfo-1.1.3.ebuild
new file mode 100644
index 000000000000..9a8fb51ef20c
--- /dev/null
+++ b/x11-apps/xwininfo/xwininfo-1.1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit xorg-2 flag-o-matic
+
+DESCRIPTION="window information utility for X"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libxcb-1.6"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+ >=x11-proto/xproto-7.0.17"
+
+pkg_setup() {
+ # interix has a _very_ old iconv in libc, however, including
+ # iconv.h redefines those symbols to libiconv_*, which then
+ # are unresolved, as the configure check is old and dumb.
+ [[ ${CHOST} == *-interix* || ${CHOST} == *-solaris* ]] &&
+ append-libs -liconv
+}