summaryrefslogtreecommitdiff
path: root/x11-apps/xrestop/xrestop-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /x11-apps/xrestop/xrestop-0.4.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'x11-apps/xrestop/xrestop-0.4.ebuild')
-rw-r--r--x11-apps/xrestop/xrestop-0.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-apps/xrestop/xrestop-0.4.ebuild b/x11-apps/xrestop/xrestop-0.4.ebuild
new file mode 100644
index 000000000000..42d0def453a2
--- /dev/null
+++ b/x11-apps/xrestop/xrestop-0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="'Top' like statistics of X11 client's server side resource usage"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xrestop"
+SRC_URI="http://projects.o-hand.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ppc ~ppc64 sparc x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}