summaryrefslogtreecommitdiff
path: root/x11-apps/xkbutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-09 23:17:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-09 23:17:55 +0000
commit8fc08491f26431ec46b36d6ebef9551f3773b96f (patch)
treed1b5bd96d856b4ddb71d02628504d39fae5c168e /x11-apps/xkbutils
parentfd1ea0a53f74daa4fd860ac35a20ba1817fd20fa (diff)
gentoo auto-resync : 09:12:2023 - 23:17:54
Diffstat (limited to 'x11-apps/xkbutils')
-rw-r--r--x11-apps/xkbutils/Manifest2
-rw-r--r--x11-apps/xkbutils/files/xkbutils-1.0.5-c99.patch43
-rw-r--r--x11-apps/xkbutils/xkbutils-1.0.5-r1.ebuild22
3 files changed, 67 insertions, 0 deletions
diff --git a/x11-apps/xkbutils/Manifest b/x11-apps/xkbutils/Manifest
index 3365215af0c9..616689d5b841 100644
--- a/x11-apps/xkbutils/Manifest
+++ b/x11-apps/xkbutils/Manifest
@@ -1,3 +1,5 @@
+AUX xkbutils-1.0.5-c99.patch 1694 BLAKE2B 8328ec46960c72206931981c447db6b3444f6c44b3722ab0d5aa1fa2efa5b18c48d0997530ddc9e7a416aaf3d13f11561bc514838ccb081c3a6cd41dd1ba8942 SHA512 f7e5a746615c3013dbc7a60082652fa29dd36f477def85786e249fb7f39127b4048b0001f1d5a0e8c9dd24cbacc43de314d352eff0dda8f41d8fd12e6ba55c42
DIST xkbutils-1.0.5.tar.xz 129344 BLAKE2B ac2572b31638120dd5c5e92497f9cde4b43df7ab0f13882f5f1fbac71084dc112a1f9e34d10adf5a4eb83b1b1636ab2388ae8675be5ac1048a3913ac7b0d7f53 SHA512 0d8d460f5e015e9034292688437511068dab61216c2493f2981cfb63aaa012976ac9435c1586a22c0940fbfcb779b48dce9b85832303fe2b854aa945b814ac77
+EBUILD xkbutils-1.0.5-r1.ebuild 441 BLAKE2B be1d8f3fbe2d9af03ccf37389e43aef4b8b69b150e7b86c7af27403246cba87c7e924554b0994b1418511171a1de3b03f538d2311e37f0b0189deba50dbe38b8 SHA512 b06828a9011d31dfeb054609c976edb3398f7700715a9e78ad5aa8280ba114faaeeb4795c36467a8fe708482f0a8052cf53c872dc8abf3a8a2a321d10ba8989b
EBUILD xkbutils-1.0.5.ebuild 384 BLAKE2B 44b1fa6c0cf58369132f2b25969977ab746a98e3e2e6e0a5efb3a4f1ac48aaeee184e5d75f3248fa94ae1408daff4408231c263b4d75074e146f6042f8bb9625 SHA512 46fe3a2533c28cfc699096c8229595794e64a63d0c08946727d23931878b92ed72226be7ce8afd66781814209487c6ff50ea7e322e82a3fa1642174242e51218
MISC metadata.xml 339 BLAKE2B 7b4be159854a72eeb269ac7349edb97862748cebb7d7b37d858dd2283f791890caeef442fa44cd804bd4a776c66666db4e327e3b8b5417d15007940702af2ac6 SHA512 bb940fa2dca293434d965d7fd443dae05b1b70dc34c2939389c367875c71a0e6c6e632dd95d2c75e0a85b682ecd6c0131030c069c50f2ada4d3782b9e238e95f
diff --git a/x11-apps/xkbutils/files/xkbutils-1.0.5-c99.patch b/x11-apps/xkbutils/files/xkbutils-1.0.5-c99.patch
new file mode 100644
index 000000000000..c396361762a1
--- /dev/null
+++ b/x11-apps/xkbutils/files/xkbutils-1.0.5-c99.patch
@@ -0,0 +1,43 @@
+https://bugs.gentoo.org/919190
+https://gitlab.freedesktop.org/xorg/app/xkbutils/-/issues/2
+https://gitlab.freedesktop.org/xorg/app/xkbutils/-/merge_requests/4
+
+From 5f875c8a6bc12d47ad655ba820031bb917f321c0 Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Tue, 5 Dec 2023 15:01:42 -0800
+Subject: [PATCH 3/3] xkbwatch: Fix -Wincompatible-pointer-types warning (Issue
+ #2)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes warning from gcc 13 that is becoming an error in gcc 14
+
+xkbwatch.c:92:34: warning: passing argument 7 of ‘XtOpenApplication’
+ from incompatible pointer type [-Wincompatible-pointer-types]
+ 92 | fallback_resources,
+ | ^~~~~~~~~~~~~~~~~~
+ | |
+ | char **
+In file included from xkbwatch.c:31:
+.../X11/Intrinsic.h:1473:5: note: expected ‘const char **’ but
+ argument is of type ‘char **’
+ 1473 | String* /* fallback_resources */,
+ | ^~~~~~~
+
+Closes: #2
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+--- a/xkbwatch.c
++++ b/xkbwatch.c
+@@ -72,7 +72,7 @@ main(int argc, char *argv[])
+ static Arg vArgs[] = { {XtNorientation, (XtArgVal) XtorientVertical} };
+ static Arg onArgs[] = { {XtNon, (XtArgVal) True} };
+ static Arg offArgs[] = { {XtNon, (XtArgVal) False} };
+- static char *fallback_resources[] = {
++ static String fallback_resources[] = {
+ "*Box*background: grey50",
+ "*Box*borderWidth: 0",
+ "*Box*vSpace: 1",
+--
+GitLab
+
diff --git a/x11-apps/xkbutils/xkbutils-1.0.5-r1.ebuild b/x11-apps/xkbutils/xkbutils-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..8c507f49ed57
--- /dev/null
+++ b/x11-apps/xkbutils/xkbutils-1.0.5-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org xkbutils application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.5-c99.patch
+)