summaryrefslogtreecommitdiff
path: root/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild')
-rw-r--r--x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild
new file mode 100644
index 000000000000..d00be953da85
--- /dev/null
+++ b/x11-apps/xinput_calibrator/xinput_calibrator-0.7.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools-utils flag-o-matic
+
+DESCRIPTION="A generic touchscreen calibration program for X.Org"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xinput_calibrator"
+SRC_URI="mirror://github/tias/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="gtk"
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-proto/inputproto
+ gtk? ( dev-cpp/gtkmm:2.4 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ append-cxxflags -std=c++11 #566594
+
+ local myeconfargs=(
+ --with-gui=$(use gtk && echo "gtkmm" || echo "x11")
+ )
+ autotools-utils_src_configure
+}