summaryrefslogtreecommitdiff
path: root/x11-apps/xinit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-07 18:44:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-07 18:44:07 +0000
commit5001a6c7b6da2956f5b17c695b1e0059dc7b8de5 (patch)
tree0528a53855a7ec96d20cde9edb9031aab030224c /x11-apps/xinit
parenta8b0d35ab742f31538d515dea39716e566d533c0 (diff)
gentoo resync : 07.01.2018
Diffstat (limited to 'x11-apps/xinit')
-rw-r--r--x11-apps/xinit/Manifest1
-rw-r--r--x11-apps/xinit/xinit-1.3.4-r4.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/x11-apps/xinit/Manifest b/x11-apps/xinit/Manifest
index 78104a2d500d..dad9918e0bb1 100644
--- a/x11-apps/xinit/Manifest
+++ b/x11-apps/xinit/Manifest
@@ -9,4 +9,5 @@ AUX xserverrc 45 BLAKE2B 768b6cce44df53b656776acb0c386aade3897e1d117a6673986a18d
AUX xserverrc.1 132 BLAKE2B f914e41cf124fb4777cb6eef3cee5e7137336961ef5cc010288b5949fff59fcdab3d2f264c91fe05ae165b6bacd63ae8b13e58b51a149b637996db346790aca2 SHA512 3cc3b18cfc8076badcae62d098a0c3cc0b654ab691b9e7a64f456f5428f1afe1130c9c033b106cfa2e566de22cb75756d71368e3c0a7474b8a76f63c1f91a918
DIST xinit-1.3.4.tar.bz2 165881 BLAKE2B 78e0b9e8fdb146e969014d726ac05e7f4cf14947aa6026642fbbe6a55eb9c5cb891f079281bb40b460f9b1373259e338dcc0615fbdda64da49b719980017b782 SHA512 ac31e4cac86fc5dd4c0e15cf37cb9ac470ef3ace4f86d0063c7e1091342fe64d41fcd12c1840bd8e1cef4cdd7f66bd2fa76bd4061641e9c70941d76d73d0df2e
EBUILD xinit-1.3.4-r3.ebuild 1913 BLAKE2B af34d5eb73f8e99ea509c577c7560d44f11f8151dafd2371d91172c395e564605bd326f8da5610a34e1b2edaad4f58f09f208a38d1d803610b641cbbc651592f SHA512 59712d0dd8ff2e7637bbd3b72a9bc067d860247eb9bb8be603211d265a3c209d59431759cffee408e4104a5d28f07fe18349e7aab1858b18944b5b6ca4467e05
+EBUILD xinit-1.3.4-r4.ebuild 1770 BLAKE2B aff5f95040e5b78e49670178dbf5ba32cf80b437aa91857acd0c6590eb60cf39f4dcc460b16519d86ea05c08e2e0fbd670e49ee4dcb5831ef79cf7cca12ada3d SHA512 bddc5e4776a5b27533fb179aa4102618f8f6a9e9afc1202f962734f5854bd4e60bddac6141fafa297060b544b633be269646a8cb3b4896f0003e2e707d2930b8
MISC metadata.xml 480 BLAKE2B 190a0b3a84e4d0d85e0928b964cb820599510c6c09a1a7c385b2f9b402a44478e08b48fce2d88216fe2fd52a3f35ec02d99cb7d738caf8a2d8dd6418e36f6125 SHA512 5dcfabd3eff26ffb33bd8ae8248cc3214c67a0fb10d5c214b2432fea7625b2555b29bb654d9712e8d55a081b25912da65ac367203fe529a860febc59fb91de55
diff --git a/x11-apps/xinit/xinit-1.3.4-r4.ebuild b/x11-apps/xinit/xinit-1.3.4-r4.ebuild
new file mode 100644
index 000000000000..ea3e115f959f
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.3.4-r4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+minimal"
+
+RDEPEND="
+ !<x11-base/xorg-server-1.8.0
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.3-gentoo-customizations.patch"
+ "${FILESDIR}/${PN}-1.3.4-startx-current-vt.patch"
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir="${EPREFIX}"/etc/X11/xinit
+ )
+ xorg-2_src_configure
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ newexe "${FILESDIR}"/xserverrc.1 xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/00-xhost
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/Xsession.desktop
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}