summaryrefslogtreecommitdiff
path: root/x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild')
-rw-r--r--x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild b/x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..12d615ee4f87
--- /dev/null
+++ b/x11-apps/xdriinfo/xdriinfo-1.0.6-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3 flag-o-matic
+
+DESCRIPTION="query configuration information of DRI drivers"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+pkg_setup() {
+ xorg-3_pkg_setup
+
+ append-cppflags "-I${EPREFIX}/usr/$(get_libdir)/opengl/xorg-x11/include/"
+}