summaryrefslogtreecommitdiff
path: root/x11-apps/xdpyinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /x11-apps/xdpyinfo
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'x11-apps/xdpyinfo')
-rw-r--r--x11-apps/xdpyinfo/Manifest1
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.3.2-r1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-apps/xdpyinfo/Manifest b/x11-apps/xdpyinfo/Manifest
index 0d28d733f4be..f153c562e363 100644
--- a/x11-apps/xdpyinfo/Manifest
+++ b/x11-apps/xdpyinfo/Manifest
@@ -1,3 +1,4 @@
DIST xdpyinfo-1.3.2.tar.bz2 141351 BLAKE2B b2dee4f424dee902c31430b8843c14d6836508ee0125db7de41f5e9faef1732dea571e90b37638cc90dabd3995a0ceb5e4094707138b7e066ee1ae856258503c SHA512 2c9097c13778c7a7fe5a9b3ee04b28512ff6028231eca91ecdf6104c742be470678920d37a4f540fece7e39dccbea34802271f359ab80618027b2856c8912e7d
+EBUILD xdpyinfo-1.3.2-r1.ebuild 778 BLAKE2B 8f9b9ea0b0e6027b114d4602376a38f79d41b26c187bb621f4a49fe03377b38c4850143160c2919168326a5f61dd3fc97247bc843a6128a757fadb6fa6ecae2f SHA512 b26dfa8a5edb6a9cb46c457098eb9348607683b69b4399a49ebd2bb49dc56c10befa34dc75ec59a4dae0c5882259097545dbfbb1b3b8a3d40288de3ad8fefa30
EBUILD xdpyinfo-1.3.2.ebuild 771 BLAKE2B 73045fa25f9ea855e98174d9086594dbe737e476774ae9a18ee59de17698ebaf5e0e3dd7830207403530e809e1e21eacada3f4a3e3cb6ad39c91b1b724e66f1a SHA512 db2b6fb02243fd4aa98ac284e72780f1ff960ce5edb616fe67d327c8bdf7c8b2c94c6bdb3adc66acb76e02d1db132c75cf7520efec9fd63b7586515f3af06589
MISC metadata.xml 347 BLAKE2B 0496b148ad07710139de96e153b80e6035e6731a18d6e8a4dce75dd17bdfc54ad77276f1f82791393d198e96c9306f464dbce832b4d643b6285fb9a6d92e6261 SHA512 98174497a1f55be4b14d769ec110dafd63a8942eb8f51e2953237b76705128e47bd36a39b9c25985cdd99a3b431f3d5aa856fd634b2a2fbfc1a5cc13a3826fab
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.3.2-r1.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..63f16db55f3a
--- /dev/null
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.3.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xorg-3
+
+DESCRIPTION="Display information utility for X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
+IUSE="dga dmx xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ dga? ( x11-libs/libXxf86dga )
+ dmx? ( x11-libs/libdmx )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ "--without-xf86misc"
+ $(use_with dga)
+ $(use_with dmx)
+ $(use_with xinerama)
+ )
+
+}