summaryrefslogtreecommitdiff
path: root/x11-apps/xdpyinfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /x11-apps/xdpyinfo
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'x11-apps/xdpyinfo')
-rw-r--r--x11-apps/xdpyinfo/Manifest2
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-apps/xdpyinfo/Manifest b/x11-apps/xdpyinfo/Manifest
index 87dc88d49419..b2fbe8a7dd0b 100644
--- a/x11-apps/xdpyinfo/Manifest
+++ b/x11-apps/xdpyinfo/Manifest
@@ -1,3 +1,5 @@
DIST xdpyinfo-1.3.2.tar.bz2 141351 BLAKE2B b2dee4f424dee902c31430b8843c14d6836508ee0125db7de41f5e9faef1732dea571e90b37638cc90dabd3995a0ceb5e4094707138b7e066ee1ae856258503c SHA512 2c9097c13778c7a7fe5a9b3ee04b28512ff6028231eca91ecdf6104c742be470678920d37a4f540fece7e39dccbea34802271f359ab80618027b2856c8912e7d
+DIST xdpyinfo-1.3.3.tar.xz 137088 BLAKE2B 8fdf49e65ac05ab27672ef2044044353f8bbfe0c8bf6135e71b9fbd45b3cb643f5794977802cbb7a44cfe9d20905b5e74b0cc41829c9fef837f32c81bb05ea2f SHA512 47fe0821bc64145876853712ebd7c0af80111c243813615b892429021cc9a53abd38c4684551ae300cb5a4eacdd3d26e2c93e789ed91a948b20e2c37cd2d2442
EBUILD xdpyinfo-1.3.2-r1.ebuild 807 BLAKE2B 9809040ba064c2c295f455a5a6ba350973348abcf8fd09e7f768831ffde5e182aee5e199147c968ecf2f441a252d8e17f3b4fbf65041a89be038bc6a50d75786 SHA512 3e7301b21af2bdb457c020aec37b9a9cab6cee2afd7f9dfa064cb4f95b9c9dff078d3bcdb2e81dbaa52c5c0c3783f5e92e5ce543b50c39d82cfebad85319b26a
+EBUILD xdpyinfo-1.3.3.ebuild 839 BLAKE2B 90960c08fe4c80cd860d8645ca16d344e8e99a92bc881b84115a3d6aeba066d01843a02c50a04d03d2c29acddcd4ee50096e3a9469480b3fcbb8e847e05e7ee5 SHA512 edb42c20bf602ed328e4eb7407b1105cba7f118580a966badc1c80a5026fccda0440fb0fb5284e24060338d3297f06e46c4f77d26c9dc9c2118f343eaac4a08b
MISC metadata.xml 348 BLAKE2B c29f79a25abe32eee42ed83aae3760812638a6696c8f27392673c9e9bb178e086b8fcc344b3db42bb9fe02ae23757ea201c8f3b5d4e03f466c6a524368df4778 SHA512 5a9e3ec8b2303c5d61cbc08cddacfe978140f9db3c5b1a2b72b896c6a61c408e6f22bcdb0a0d4e7542d946397a11878d1ca38c2e9e6cf211ad3b45eb1a45f914
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild
new file mode 100644
index 000000000000..1be291758419
--- /dev/null
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.3.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="Display information utility for X"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris ~x86-winnt"
+IUSE="dga dmx xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ dga? ( x11-libs/libXxf86dga )
+ dmx? ( x11-libs/libdmx )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --without-xf86misc
+ $(use_with dga)
+ $(use_with dmx)
+ $(use_with xinerama)
+ )
+ xorg-3_src_configure
+}