summaryrefslogtreecommitdiff
path: root/x11-apps/xdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
commitcf7807d7aea23a99a144afceaba961cfed652b5f (patch)
treeffd2c781c27e0b7e72152a685a04938a2b7966f0 /x11-apps/xdm
parent7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (diff)
gentoo auto-resync : 11:03:2025 - 01:49:36HEADmaster
Diffstat (limited to 'x11-apps/xdm')
-rw-r--r--x11-apps/xdm/Manifest2
-rw-r--r--x11-apps/xdm/xdm-1.1.17.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/x11-apps/xdm/Manifest b/x11-apps/xdm/Manifest
index 70faf32598f1..3f21d6460b84 100644
--- a/x11-apps/xdm/Manifest
+++ b/x11-apps/xdm/Manifest
@@ -1,4 +1,6 @@
AUX Xsession 1521 BLAKE2B cb2090c2f2c1626df08fe45e80ab668ec9ca43f8f647f9a16d09e7cde7fa33964cbc4f51aa41a537a027749e40c69c3f8543c41924d9d05b54226a0e4400a3a1 SHA512 6cb72d93ab8004e42e9f5002f7f8bb6eb7d9833fd7d3fb0acf7b7b481ead5fb55cb1b836a1e6010fe859e9e04e14064c442e23fdde5991ffb8556ed5aa5af555
DIST xdm-1.1.16.tar.xz 420072 BLAKE2B 1a970b99a0848b0bcb55870c1665281afc355685b4e08148cefd953456fbed5dc71a9a66fa670e80f07de3502615e3c2e81293e9476f04ce965d73be5365bd9e SHA512 a7e0aca67b770b3939aee2c12feac3c0f5efa531ec4a6045ab8b53d9c35b701ab5533447feb39b7cbe0df74ff8483ee1637314b847b37a6c3f7e9c8fdf5e172d
+DIST xdm-1.1.17.tar.xz 425804 BLAKE2B 795a7fbfb78da298631dd42990220c74f19e58233d20fda6c42517a1bd0d24ff97e74e1aed2d6acc9f81ca0b19194a2b6b2f13b656582e6ec3f23a3b23754cc2 SHA512 68499cdf73c9b6b48b974a724e5d045bb8333cfd17f1d7e36132e7aec51922c22260b361517c4f0d9fb7d28ce4909e0638e00180e93544bc7200d9bef55e822b
EBUILD xdm-1.1.16.ebuild 1773 BLAKE2B fc02db6c9c7ea6284129c56d1c7fe865ff0d8d8162d1b7a2a82a188210c00865cb14b55a965f89a4c85e6adb3a340e3244fb91b3a1da41027328090a9a8a35b3 SHA512 267da6060b02faa3d0f5855346486b5a24cf18842f37681fd0fa6661604c93380c783a4ab65242680e15442a3e9186513b57846382e2816a7b33102e4bcb3ee1
+EBUILD xdm-1.1.17.ebuild 1780 BLAKE2B ff0da8bbf1e653978df862da27322eee11df7e08884e77085e4c9210dd4a1cb7397ec86407c607a7c69f13fdc5eb4eebc1fe8bbf39ba58edd05d97bd7fa8c289 SHA512 0bed70e9b641e61ab59d8a30830818d16694763970dabfa58d093fa3bfb6279876a714413d3feaa8664e110b5ec26eb32da0769b48410992f00ce2c7639bae6c
MISC metadata.xml 334 BLAKE2B bb9f203babfde01fc5cce539d89df522147c0a2e58fea1453f826749fa1399722e3dbaf301a2e23509c074c757ff25676bf67ef0b9f1c0ed958f909778ba1dbe SHA512 361b9416bd1b55df4466e419b407c2ce3d4eabefb301cab1c702c8fc961de78ab28894550cb1287418d3398b2611fa60ddfe370cd506be863eeddf2792f75b25
diff --git a/x11-apps/xdm/xdm-1.1.17.ebuild b/x11-apps/xdm/xdm-1.1.17.ebuild
new file mode 100644
index 000000000000..6a30e45d15dd
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.17.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xorg-3 pam systemd
+
+DEFAULTVT=vt7
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="pam systemd truetype xinerama xpm"
+
+RDEPEND="
+ x11-apps/sessreg
+ x11-apps/xconsole
+ x11-apps/xinit
+ x11-apps/xrdb
+ x11-apps/xsm
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXaw
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ virtual/libcrypt:=
+ pam? ( sys-libs/pam )
+ systemd? ( >=sys-apps/systemd-209:= )
+ truetype? (
+ x11-libs/libXrender
+ x11-libs/libXft
+ )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )
+ elibc_glibc? ( dev-libs/libbsd )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ sed -i -e 's:^Alias=.*$:Alias=display-manager.service:' \
+ xdm.service.in || die
+
+ # Disable XDM-AUTHORIZATION-1 (bug #445662).
+ # it causes issue with libreoffice and SDL games (bug #306223).
+ sed -i -e '/authorize/a DisplayManager*authName: MIT-MAGIC-COOKIE-1' \
+ config/xdm-config.in || die
+
+ xorg-3_src_prepare
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ $(use_with pam)
+ $(use_with systemd systemd-daemon)
+ $(use_with truetype xft)
+ $(use_with xinerama)
+ $(use_enable xpm xpm-logos)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm
+ )
+ xorg-3_src_configure
+}
+
+src_install() {
+ xorg-3_src_install
+
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe "${FILESDIR}"/Xsession
+
+ use pam && pamd_mimic system-local-login xdm auth account session
+
+ # Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
+ keepdir /var/lib/xdm
+}